Cannot connect to iTunes store

Forum
iOS & iPadOS
Hey Everybody, I've been getting an error message since updating to iOS 6. I first noticed it when I was going to check out Passbook. When I clicked the appstore button, the error message: "Cannot connect to iTunes store" came up. Now when I open the appstore from my home screen, the first (featured) tab works, but when I try to switch tabs I get that same message. I've gone into settings and made sure all of my payment info and everything else was correct. I can't think of anything else to try. Any ideas? Anyone else have this problem? Device: iPod Touch 4g

Options

Comments

Submitted by Signaltonoise on Friday, September 21, 2012

I've been having the same problem with my iPhone 4S

Submitted by AJ M on Friday, September 21, 2012

So far the only tab that works correctly is the updates tab whenI switch from featured. Clicking on the genius tab kicks me out of the app. I wonder if this only occurs with VO users.

Submitted by Lisa on Friday, September 21, 2012

That's an odd issue, I've had no issues in the app store whatsoever using voiceover. I've already updated old apps, as well as downloaded new ones. Not sure what would be causing this, but it doesn't sound like a VO issue.

Submitted by Dom on Friday, September 21, 2012

In reply to by Signaltonoise

Hi, I've been doing some research, and your not the only one with this bug, but look at this link: it tells you how to fix the bug: http://www.idownloadblog.com/2012/09/20/fix-for-cannot-connect-error/?utm_source=twitterfeed&utm_medium=twitter&utm_campaign=Feed%3A+iphonedlb+%28iDownloadBlog%29

Submitted by Dave Nason on Friday, September 21, 2012

Member of the AppleVis Editorial Team
I was having that issue sporadically too, though it hasn't happened at all today. I wondered if it might have been connected to the reported wifi issues, which are supposably now fixed.

Submitted by AJ M on Friday, September 21, 2012

After I read the article above: (check comment #2), my first reaction was pretty much, yeah...sure...why would that work? But after trying everything else *disconnecting and reconnecting my wi-fi and anything else* I decided to give it a shot. For anyone else having the problem I was having, here is how to fix it...I don't understand why it works, but it does for some reason. *How to fix issue with connecting to app store from passbook app* *go to settings/general/date and time *change "set automatically" to off *choose "set date and time *change the year to 2013 *open passbook app *try to launch app store from within passbook *You will either get an error message or just land on the featured tab *go back to settings *change the date and time setting back to "set automatically" *launch app store via passbook and you should land on the passbook apps page Like i said, I don't get why, but it does work. Thanks to Dom for the link.

Submitted by John Gassman on Saturday, September 22, 2012

I didn't do anything to accomplish this, I just tapped on passbook and was able to connect and see all the applications that were usable with Passbook. At first I thought, that perhaps I had to have the iPhone 5 to use it but evidently not. I have the 4S and IOS6.

Submitted by Signaltonoise on Saturday, September 22, 2012

I tried the fix that was written out in the article and I'm still having the problem. Is there another workaround or do I need to contact Apple on this? Thoughts would be appreciated.