Bug in Notes App

iOS & iPadOS

I ran into this problem with the native Notes app on an iPad Mini 4. It's possible this problem is limited to the iPad, since apps often have different interfaces for iPads than they have for iPhones and iPods.

While editing a note, if the iPad is in portrait mode, there is no VoiceOver feedback as to what is being typed. There is no echo, regardless of the typing echo setting, and if you try to navigate the text field by characters, words, or lines, you hear sound effects indicating that the cursor is moving, but no speech telling you where you are in the note.

If the iPad is in landscape mode, the bug does not occur, and I can interact with the text field normally. However, if I bring up the Notes app through the iPad's split view feature, the bug still happens, even in landscape mode, so I must use the Notes app in full screen mode and in landscape in order to get proper VoiceOver feedback.

I don't use the Notes app often, but the bug definitely did not happen the last time I used the app, which was a couple of months ago, so the bug must have been introduced in an iOS update since then. The bug continued to occur after restarting VoiceOver, restarting the Notes app, and restarting the iPad as a whole.

Can anyone else with an iPad reproduce the bug? How about on other iOS devices? I plan on submitting a bug report to Apple Accessibility, but I want to know if others are observing the behavior first.



Submitted by MsHollyWeezy on Friday, June 3, 2016

Hi. I use a iPad Mini 4 and used the notes app and have not seen this bug. I have my iPad in portrait mode. I tried typing in Braille screen input and on the regular keyboard. Also navigating by line and all that works fine to.

Submitted by dvdmth on Friday, June 3, 2016

OK, try this.

While the on-screen keyboard has VoiceOver focus, do a two-finger scrub gesture. VoiceOver should say, "keyboard split."

Now see if you can reproduce the bug.

After testing, repeat the scrub gesture on the keyboard to bring it back to normal.

It appears that I accidentally split the iPad keyboard without realizing it. Once I merged the keyboard back to normal, the bug I described disappeared. The funny thing is that I normally use a Bluetooth keyboard when typing, so the on-screen keyboard is normally hidden from view. Even so, the fact that the keyboard was split, even if invisible, was still causing me problems in the Notes app.

I am now wondering if having a split keyboard introduces problems in other apps.