Anyone having problems deleting texts since the latest IOS update?

Forum
iOS & iPadOS

Since the latest IOS update, is anyone else having problems deleting texts? Up until now I've simply swiped on the text message in the list before its opened and when it says delete I just double tapped and it went.

Now, since the last update, swiping on the unopened text message still says delete, but when I double tap, nothing changes. It's only after I've turned off the phone and restarted it that going back into messages shows that its gone. I've tried this out on 2 different phones which are both updated, but I get the same from both - nothing unless I turn the phone off and on again. Prior to this last update, everything worked fine.

Any ideas?

Thanks. Debbie

Options

Comments

Submitted by Tyler on Monday, October 2, 2017

Member of the AppleVis Editorial Team

This is a known bug in iOs 11. Instead of using the rotor action, you might want to use the edit button and select the thread you want to delete until this is fixed. Closing the Messages app via the app switcher may work to delete the message as an alternative to fully restarting the phone.

Submitted by hamiltonthemus… on Monday, October 2, 2017

I can delete them OK, but my phone is randomly deleting conversations that I don’t tell it to dilete. Is anyone else having this issue?

Submitted by Chris Smart on Tuesday, October 3, 2017

the issue I had with most iOS 11 betas, and with the 11.0.1 release, was with conversations not being removed after I attempt to delete them. They only disappeared if I force quit then relaunch Messages.

I can say that this problem is fixed in 11.1 beta, along with some battery drain issues, if you're willing to run beta software.

Many thanks to all that have suggested closing the message app to get rid of unwanted messages. Its certainly quicker than restarting the phone!

I'm interested in the Beta software which has fixed this bug, but haven't a clue how to run it and what are the risks?