Any way to disable automatic switching to speaker

Forum
iOS & iPadOS

<p>Hi all, A very frustrating problem of IOS is the fact that when you move the phone away from your ear whilst talking, the speaker is automatically activated. This does not work properly at the best of times and mostly just switches back and forth between the ear peace and the speaker. I have not yet found a way to disable this, but is there a way to do it through jailbreaking? Has anyone ever contacted apple accessibility regarding this? Last time I remember sending an email about this, I was sent the normal auto-responder email.</p>

Options

Comments

Submitted by Serena on Saturday, June 13, 2015

the reason you won't get a response from them in terms of a bug, is because it's not a voiceOver bug. it should, while using voiceOver only, do this. it will not do this while not using voiceOver. it's there, so that when you take your phone away from your ear, you will be able to use voiceOver. as voiceOver will not come through the outside speaker. if you are having problems with this function happening while you actually have it against your ear, that is due to you having a defective proximity sensor, which may need fixing.
sometimes, the proximity sensor, can be fixed with software, as iOS is updated. but it could actually be damaged or not working properly.

how ever, if you are talking about it functioning in it's normal way, IE, you take the phone away from your ear about an inch or two, and it switches, this is normal, and is there for a reason. and no. there isn't a way to disable it. i don't know about breaking your phone, as i refused to do that with my devices. there might be, but i don't know.