Any advice on solving quirks with relabelling in iOS?

iOS & iPadOS
So I'm trying to tidy up the labeling of some buttons in an iOS app using VO's two-finger double-tap and hold gesture, but experiencing some quirky behaviour. Most of the time, I relabel a button, it updates instantly, and stays that way. All good! Sometimes, I'll relabel, and the change doesn't seem to have been saved. Then at random, VO will suddenly start using the new label. Manual refreshes, reloading the app etc don't seem to trigger these Eureka moments, they can happen anywhere up to about 5 minutes after setting the custom label in my experience. The behaviour that's currently stumping me is that there are two outstanding buttons left to be tweaked. One of these I've previously set a custom label for, but now that I have a better understanding of how the app works I'd quite like to change that label. I've tried changing it, clearing the field completely, even changing it back to what it was set to out of the box, but VO seems to have grown attached to the custom label I'm trying to get shot of. The other outstanding button is stubbornly refusing to change from its stock label. At first, I thought this was a repeat of the behaviour described above where VO will randomly start to use the custom label, but it's been several hours now and no joy. Functionally there's no obvious difference between this button and about 5 others on this particular screen of the app that have accepted custom labels with no drama. If anyone can think of anything I haven't tried or offer any advice, shoot. I'm two buttons away from a beautifully accessible app, and whilst not being a deal breaker in terms of usability, the OCD is overwhelming LOL!



Submitted by John Gassman on Sunday, November 4, 2012

I've labeled my folder scanning. When I move over to page 2 on my screens, I see that my utilities folder has also been renamed scanning. If I try and rename my utilities folder back to utilities, it changes that folder and my scanning folder to the utilities title. I wrote to Accessibility at Aple about this weird behavior and they said they were looking into it. I hope that this is true and that they're not just ignoring the issue. I wonder if anybody else has had this problem starting with IOS 6? IOS5 worked fine!

More Like This