“Activate (VO+Space) on iPad13.4 & .5 broken?

Forum
iOS and iPadOS

Hi all. My first post ever here ;-)

I would need some help in finding a way around a new “feautre” in iPad OS since the Mrch update (13.4). The keyboard shortcut for “Activate” (VO+Spacebar) acts in a new, sometimes erratic way that is driving me nuts.

Let’s take Mail.app: I start scrolling the list of emails and when I want to select one to read it or copy tet or whatever action, I was us8ing thye usual “Activate” key combo. ButVO+Spacebar now oepns a sort of contextual menu allowing me to Reply, Reply to all, Delete.... There is not even an optin to “Select”or activate. The only way out is to use ESC (a quite awkward vO+grave accent, in my keyboad language). And then, even worse, the mail may or may not ahve been in fact selected. Cannot find a logic.

Same bizarre “I won’t select what you are clicking on but open a new floating menu” happens in iMessages, in some parts of Safari... and even in some third-party apps such as twitter. It is like having performed a long press or right click, except it is not.

I tried to assign a different keyboard shortcut to “Activate” but to no avail: same things happens.

So this must *not* be an error according to Apple, as the same things still happens in iPad OS 13.5. I am forced to remembver to select with finger double-tap onthe sceen in those places where I have discovered this “activate does not activte” behaviour, but I find new surprises each day, and being forced to switch between keystrokes and figer taps for a simple activate is beyond frustrating. I am finding myself replying to emails different that the oens I ntended as the activate shortcut did not select the email I thought it will etvc.

Is there any way to “fix” this? Or a way around?

Thanks in advance.

Options

Comments

Submitted by dvdmth on Thursday, May 28, 2020

Club AppleVis Member

I am unable to reproduce your problem on my iPad Mini, but I can see how it might happen depending on how responsive your device is, especially in the Mail app which is pretty sluggish on my iPad.

There is an accessibility setting which controls how long you must tap and hold before the context menu appears on screen. To change it, go to Settings, then Accessibility, then Touch, then Haptic Touch. There you can choose between fast and slow responsiveness to the tap and hold gesture, with the default being fast. Try changing it to slow and see if that helps.

Submitted by Mussol on Saturday, May 30, 2020

Thanks a lot for the advice. My issue, though is not with finger tapping, which indeed works as before, but when using keyboart shortcuts on my SmatCover or external bluetooth keyboard. It It is the shortcut VO + Spacebar which has changed behaviour sincer March.

Submitted by dvdmth on Monday, June 1, 2020

Club AppleVis Member

I understand what you're saying. Pressing VO-Spacebar actually causes a simulated tap on the screen, the same as if you do a double-tap. There is no difference as far as the OS is concerned.

What I think is happening is that there may be a latency when using the keyboard to perform the activation. I was able to observe a noticeable delay when I pressed VO-Space on my keyboard, from when I pressed the key to when the activation actually occurred. The latency was particularly noticeable in the Mail app, which is one of the apps you're having problems with. What I'm thinking is that the latency is causing the simulated tap to last a little longer than it normally does, and if it is active long enough then it can cause a haptic event instead of the regular tap event. That would result in the symptoms you're seeing, even though you're using a keyboard instead of touching the screen.

Again, I don't know if changing the haptic setting will work around your issue or not, since I cannot reproduce the bug on my iPad. I am only suggesting it as a possible thing to try.

Submitted by Mussol on Saturday, June 6, 2020

Thanks a lot, again. I tried to change the Haptic settings to “slow” in the keyboard, as they cannot be completely turned off... and it still happens the same: VO+spacebar opens the contextual menu instead of activating the tiem.

So time to file a bug report to Apple.....

Submitted by John M. on Saturday, June 6, 2020

I experience this same behavior on my iPhone SE running 13.4.1 and iPad Mini 4 running 13.5.1. This was not a problem on 12.4.1, which I was running on both devices until a few weeks ago.
I changed the touch setting as suggested and observed the following. The problem was resolved in the Messages app. The problem persists in the Mail app. As I use the Messages app much more than the Mail app, I am thrilled that this tweak fixed one of the issues.

John

Submitted by Mussol on Sunday, June 7, 2020

Thanks Morgan: Up + Down arrow worked, yes!

I am quite new to VoiceOver and knew nothing about that alternative keystroke. Having to learn the long list of commands is quite a work, and it would certainly help if Apple would not force me to learn alternatives for basic bunctions with each system upgrade ;-) But now I have something that helps until they fix it. Just need to get used to VO + Space in some palces and Up+Down arrow in other places...

Submitted by Morgan Watkins on Sunday, June 7, 2020

Member of the AppleVis Blog Team

I have had the same problem with the VO-Spacebar for the last couple of updates. I've seen it in multiple apps while using my Apple Magic keyboards and an iPhone XR. It is maddening. Although it is not limited to Mail and Messages, it really is a pain there. And, the problem does not occur 100% of the time. I also discovered that the Up and Down arrow at the same time almost always works. I sent this concern to the accessibility team several weeks ago, but suggest everyone else do the same.

Best wishes,

Morgan