Knight Commander Update Help

Forum
iOS & iPadOS Gaming

I was thrilled to see an update for Knight Commander. But now I don’t know hoe to make the people do anything. Long pressing on them makes a menu come up that asks which fist you want to use. Nowhere in the game is there a way to tell them to gather water, hunt, gather wood, etc. And the contract orders are gone. So you can’t choose from a list of available contracts any more. Can someone help me? Really wanting to play. Lol.

Options

Comments

Submitted by Bellsfurmama on Monday, September 28, 2020

Got the game to work but after building a saw mill, completing a contract, nearly completing a second one and having about 30 planks the game lost all my progress. Now I am at the beginning. Only difference is I have 5 people. Please help!

Submitted by Ashleigh Piccinino on Saturday, October 3, 2020

Hello,
The original game I got once seemed too simulated in the fighting. it seemed like the noises of people getting hit were CGI somehow. sure wish this could get fixed to where you can really hear the war stuff going on. Also, it seemed like a simulation when you were supposedly doing something else to fght as well. That didn't seem right to me/how can you do both? you can't in real life, so why here?

Submitted by KE7ZUM on Saturday, October 3, 2020

I think this was brought up already, but when in the fight screen and I choose a player, the game appears to crash, and crash hard. I'm not in the beta, so dunno if this has been looked at. Also, that fight screen is confusing. for example, how do you add the weapons you created to each player etc. There is no manual per say I can read on how to do any of this.

Submitted by Bellsfurmama on Saturday, October 3, 2020

The fight bugs have been fixed. The new version isn’t out though. Fighting was never my thing so I’m not sure about a lot of it. I did it a few times in the old game to gain manna but that was all.

Submitted by Bellsfurmama on Saturday, October 3, 2020

New sounds have definitely been added so I imagine the fighting sounds are different as well.

Hello,
right now, the fight screen sucks for me! I don't know how to use it for one thing, and when I click on a player without turning on one of the directions--for both me and the enemy, an annoying noise is heard and VoiceOver doesn't do much of anything it seems. Also, what does the 0 level 0 stuff mean on the enemies? does it mean there's no one there to fight? What's with the hospital/can't access it/don't have any music like before. this is a really problematic/sucky version of the game/wish the dev team would go back to the original. at least there, I knew what I was doing.

Submitted by Bellsfurmama on Sunday, October 4, 2020

The sound is in the options menu. That can be found under shop. It really should be in its own place and not under shop. Not sure about the fight screen. It makes no sense to me, but as I said, I played for the building and crafting, not the fighting. I would contact John about your thoughts.

Some features are not totally working as this is a test version. They released it, but only to test the main structure. So I would imagine changes are being made big time behind the scenes. Maybe see about testing it in Test Flight?

Submitted by Bellsfurmama on Sunday, October 4, 2020

I had a hard time figuring out how to build the saw mill at first. It’s in buildings. But you have to have a few things first. I think bricks is one, and a simple axe. Not sure.

Submitted by Bellsfurmama on Sunday, October 4, 2020

You need wood, brick and a stone knife. So, to make brick, focus on wood, water and then clay. Get an axe and use the chop down tree option. You’ll get wood a whole lot faster in the long run. :)

I have never used Test Flight either. Downloaded it once but that’s as far as I got.

Submitted by KE7ZUM on Sunday, October 4, 2020

the slots are full. Testflight is easy, just share the link in drafts or notes or what ever, then tap it in iOs, and click join beta.

Submitted by Ashleigh Piccinino on Tuesday, October 6, 2020

In reply to by KE7ZUM

This should also have a self voicing option, but that's too difficult to do/needs a lot of actors and things. what do you bet it's just some TTSs they use for the people talking? Also, there should be another way to gain mana than fighting--which doesn't work at all for me right now and completing contracts. Where to the extra people come from anyway, different tribes? It would be nice to actually go to their tribe and physically ask them to join your team/a little of PR work, ya know?

Submitted by vue on Tuesday, October 6, 2020

found a bug with the super machine. cant seem to buy a super machine even tho i have the required energy or mana can someone report the bug. thanks

Submitted by KE7ZUM on Monday, October 12, 2020

so question. How do I assign weapons if I can create them? as when I try I keep getting left fist right fist for what they can use. I'm very confused about this. Right now I have no choice but to fight to gain mana as I goofed.

Submitted by vue on Tuesday, October 13, 2020

to equip wep/armor double tap and hold on the villager u want to equip then pick the left or right hand to equip them with.

Submitted by KE7ZUM on Tuesday, October 13, 2020

I think I tried that, but I'm not sure. Let me make some simple sticks and see what happens.

Nope, nothing happens at all. I double tap and hold and nothing happens for me to pick the weapon etc that I want to equip. I tried from the fight screen and no joy, I tried from the main screen, and no joy.

Hre is a link as to what is going on. As you can see, it doesn't work at all.

Submitted by vue on Tuesday, October 13, 2020

don't do it in fight. in the regular menu when u pick your villiager to do a task. instead double tap and hold for a few sec. then swipe left or right to see if it work. if not then double tap and hold the villager name for a few sec then tap the screen once it should show you his eq etc to equip him. oh and swipe left or right to see if it works.