Announcing the release of Serania - Path of the Scion, a rich text adventure RPG with full support for VoiceOver

Forum
iOS & iPadOS Gaming

I'm happy to announce that my game Serania - Path of the Scion is out on iOS and Android.

It is a choice-based interactive fiction game with RPG elements like combat, character stats and free movement. Set in a Nordic culture inspired medieval fantasy world, you play as a villager, who is suddenly being hunted by the king's Blackblade soldiers for some reason. You must escape and explore the realm to find allies and clues about your ancestry to solve the mystery.

The game has sound effects and music to add to the atmosphere of the story. I had the privilege of working together with a few blind players from this forum during the beta testing to fine tune the VoiceOver and TalkBack experience. I hope you will like the result.

Serania - Path of the Scion is available on the iOS App Store and on Android Google Play. First part of the story is free to play. Unlocking the full story is $3.99.

Options

Comments

Submitted by Ashleigh Piccinino on Saturday, February 6, 2021

The subject says it all. I’m downloading it now, and as I opened it, I hesrd some really good Medieval music. Let’s home it keeps going!

Submitted by Ashleigh Piccinino on Sunday, February 7, 2021

Hello,
This is a good game so far, but I've noticed that whenever I'm on "say all" and VoiceOver says "next" it stops as if it's at the end of the text. however, it's not, and I have to push the say all command again--I'm not going to sit there andd arrow right everytime the text switches. To get around this, I've went to the bottom of the page and up to my stats and things--using a bluetooth keyboard with my copy of the game. Also, hintsd don't seem to work so why?

Thanks for bringing this up. A core design decision of this game is that you gradually reveal pieces of text by right swiping. This is to create an experience where the story happens as you read it, with the sound effects timed to the text.
The intented way to play the game is simply that you right swipe through the text pieces, and at some point you reach the choices. Some users have pointed out that VoiceOver uttering "next" on every swipe is anoying. This has just been fixed in version 1.1.6.
Please note that there is a custom VoiceOver rotor control in the game as well that can be used to navigate quickly to top, bottom and choices by swiping up or down. It can also be used if VoiceOver for some reason looses focus. Just swipe down once, and it will put the focus where you left of.
Regarding the hints: They are shown when tapping the "hints and help" button, but there at not always hints available, depending on where you are in the story.
Hope all this helps, otherwise let me know :-)

Submitted by Ashleigh Piccinino on Monday, February 8, 2021

Hello,
If spelling and grammar errors were arrows, this game would be poked through/I'm finding many of these errors. Also, yes, the "next" speech is getting to me. however, the sound effects are good. The music, though, doesn't last long, so why? Also, if players go to the forest and the White Tempel first, can they ever get back to Baugon or however it's said later on? I'd like to get trained in magic a bit before trying to defeat the Gragnock or whatever that thing is in the smuggler's tunnels.

Submitted by DMNagel on Monday, February 8, 2021

You can certainly go back to the city whenever you want.

Submitted by Ashleigh Piccinino on Monday, February 8, 2021

isn't ready for primetime yet, it doesn't seem!
Why do you keep getting pushed back to the main menu? it doesn't seem as if this game's ready for the big screens--primetime, that is. do you have this trouble as well? I think the dev team, including Mr. R. should get some writing tips from the author of Timecrest. the game just doesn't seem to flow as smoothly as Timecrest for me but it's still fun. Note all of the spelling/grammar errors, too? to me, it takes away from the excitement and all when I hear these. however, Mr. R. might've been writing fast, and that's okay. yet, I think he needs to be further guided in the writing process, so ... just my thoughts/sorry for being so critical. and I'm not even an English major but one of psychology haha!

Submitted by Peter Ravnholt on Monday, February 8, 2021

In reply to by Ashleigh Piccinino

Sorry about the grammar errors, some must have slipped through the proofreading process. Reported errors are being fixed, and I'm looking into improving the proofreading process.
Upgrade to version 1.1.6 to fix the "next" speech issue.
The music was made to stand out with specific themes. It was decided not to loop these to avoid tiring the listener.
Can you elaborate on the issue of getting pushed back to the main menu?

Submitted by DMNagel on Monday, February 8, 2021

In reply to by Ashleigh Piccinino

At least it's a one time purchase. No time crystals here. I for one enjoyed it. I just wonder if there is any use for the fruits, the crab claw, The trout and all the stuff at the wood shop except the firewood? Also, is searching for berries the only skill?

Submitted by Ashleigh Piccinino on Monday, February 8, 2021

In reply to by Peter Ravnholt

hello,
I get pushed back to the main menu sometimes, and I don't know when that'll be/why. however, if you have access to reception of screen recordings, I'll try to have one ready when I play again. Also, what do you do at the brewery? I've, of course, never worked in one of these in my life, but it seems unclear as how many times to put the grain/water mix into the metal "conindar-like" tub. Also, what's with the inn? Why can I only work there once/how will I know that someone needs help? One more thing, I like that kind of thing when the music's good, to have it on a continuous loop. I've watched my siblings play the Zelda games on Nintendo, and I've, of course not played but listened to the music and all, thinking it was cool -- well, mostly, anyway!

Submitted by Ashleigh Piccinino on Monday, February 8, 2021

In reply to by DMNagel

The subject says it all. You know what Egil said about not trusting anything from Borgan, right? That would include, of course, the foods and stuff. Of course, things at "The Golden Barol" seem good enough. however, the trout seems bad--the fruits seem "overripe or even rotting," and the crab claw ... well, you have to have something to smash it open/crush it to get to the meat. Please use "examine" more than you do. I guess it's just me, but I like to know about things.

Do you know what to crush the crab claw with? All I get is the message telling me that I need to crush it. It's actually quite funny. I was able to finish the entire game, yet I can't seem to get a grip on the simple stuff, like eating a crab claw. Lol.

First you must fill the bucket from the wooden vessel, then empty it into the metal vessel. Now fill it from the metal vessel, then go up the ladder. Pick up the rake, empty the bucket onto the floor and use the rake to even out the grain. You must work at the inn, the Brewery and the library. When you are done, you can work at the in again.

Submitted by Ashleigh Piccinino on Monday, February 8, 2021

Thank you all for your comments. It's not real clear what you have to do, and how do you get past that damn fog in Lake Skagi? you know, some of these names are like those in the Ice and Fire series--Lake Skagi could be the Skahisadon or however it's said. Anyway, how do you get past that fog? Also, horseshoe won't work for crushing the crab claw, and remember about the trout and Viskarian fruits--I'm not looking at how things are spelled here, so ... Also, the man at the library won't let me in, even if i offer to pay for the knowleddge, so how to get in?

Submitted by DMNagel on Monday, February 8, 2021

When Rowing the boat, examine your crystal. To get into the library you must by mint tea at the stalls and pretend to be the tea guy.

Submitted by Ashleigh Piccinino on Tuesday, February 9, 2021

Thank you for this. However, without magic, I might not be able to examine the crystal? I know the other guy ... Gorgen ... has one but he cant use his. Must I go with him first before going to Borgon? All this is confusing to me, and I'm not getting anywhere with the Gragnok, although I killed it once. I then went for the rat but died, so I'm wonderinf how to kill the gragnok without dying myself? What should I be looking for when I examine the crystal? of course, I'm new at this, so ...

Submitted by ftealucard on Tuesday, February 9, 2021

Hi all
Enjoying the game, a few comments/questions.
I assume there is no way to maximize all stats and afford the best equipment since there is no place to grind experience and a limited amount of gold in the game?
I'll try not to spoil much for those that haven't finished but I am stumped and slightly frustrated at a section that hasn't been mentioned yet.
How do you distract the monster in the city tunnels? I am starting over because I can't figure this out. I tried the tea and all food from the city venders but for the bread which I assume is just for healing. I figure something from the brewer but I can't enter since I finished the work for him and mistakenly clicked the wrong choice when you had the choice to help with the making of beer for the king. I am starting over to see what I missed but I swear I payed attention to everything. I'm sure I'll kick myself when I hear the answer. Please contact me privately if you don't want to spoil the answer in a public message.
I understand this game is more of a story with RPG elements instead of a full fledged rpg. However it got me thinking that a game like this, combined with a bit of Land of Livia, Untold RPG and the browser based RPG Sryth would be quite spectacular. Turned based combat, easy way to compare equipment so you can always equip the best you have at the moment and a few locations where if the player wants to spend many many many hours to power level, they can choose to do so. I would gladly pay $20 or more for something like that.
Thanks for any help.

Submitted by Ashleigh Piccinino on Tuesday, February 9, 2021

I just wonder if you can use a bit of magic for that, fighting the gragnok in the tunnels. I also wonder how to distract it, but it seemed, when I killed it first time, the bad fruit and fish were enough ... in smell only to properly distract it. however, what about magic. the swamp dragons are good practice, I guess to just try whatever you can on them. yes, having all three games put together would be nice ... and having this game move a lot more smoothly--seems choppy still yet with all the stops for you to swipe to new text. that's not how those other games go, so why this one? Also, found out that I get pushed back to the main menu mainly whn my experience levels up. other times, too though.

Submitted by DMNagel on Tuesday, February 9, 2021

You can just paralyse the monster with magic and chop him to pieces. When crossing lake Stagi, ask the old man for directions in the boat. When his crystal dies, you must examine yours.

Thanks for the info. I'll take a look at what you suggested. I'll also try the fish and fruit again but I swear I remember during the fight the only option I had was examine. Do you have to drop them instead?

Submitted by DMNagel on Wednesday, February 10, 2021

In reply to by ftealucard

There is nothing that suggest it works. It's better to just get paralysis magic and use it on the monster instead.

Submitted by Tarja on Wednesday, February 10, 2021

I showed my crystal to forest folk but they don’t believe me. There are no hints. What should I do?

Submitted by Anthony on Wednesday, February 10, 2021

After you show them the necklace and I don’t believe you you have to show them the note with the seal and then the guy will take you to the leader of the forest people

Submitted by DMNagel on Wednesday, February 10, 2021

Don't give berries to Jorgen at the white temple. Give him bread instead. Also, don't taste berries when Egil tells you to. Save them instead. Those berries are very precious and comes in handy at the end battle. Berries can be found in front of the white temple and in the clearing of the forest where you woke up. Along with the berries that Egil gave you, you should be able to have 3 uses at the end battles.

Submitted by Ashleigh Piccinino on Wednesday, February 10, 2021

Hello,
I'm done with the game, although I thought I was going to die a couple times there in the end. However, with no Rami berries, I managed to use magic to stave off death/win. anyway, what's next for this company? I really liked the game but added my comments on an e-mail you can/will be able to send them at the end. I honestly thought the Aura/Wiggas part was oddly familiar, like Deneris and Her Cal Drogo in the Ice and Fire series. That party made me cry as well as the part where Turi tells you what she does about experience bettering your skills. That's so true, even today with people with disabilities learning their ECC stuff. She was right there, so what's next for these people? I'm excited to see another story based on this/possibly, Aura's later adventures with Serania--by the way, a good name for a little girl, don't ya think? What do ya bet Mr. R has a girl with that name, Serania .../would possibly name my kid that if I had one/when. Wanna know how he got the idea for this, just in a historical venture, ya know? In letting the Forest Folk join you, it might be a good thing to help with the Lasart's killing, just to make them see that you're a friend and not a foe.

Submitted by Ashleigh Piccinino on Saturday, February 13, 2021

Hello,
I've just found out that bug@fabletreeproductions isn't the right address/doesn't work any more. I've been trying to send a screen recording to the developers of this game. however, it doesn't work with that e-mail addres. can you give me another/see why it doesn't work? I typed it in correctly too, so ...

Submitted by Peter Ravnholt on Saturday, February 13, 2021

Congratulations on completing the game :-)
Looks like you are missing .com at the end of the email address. The correct address is:

bug@fabletreeproductions.com

I just verified it to be sure. If you are still having trouble getting it through, you can try sending me a direct message here on AppleVis.

Submitted by Ashleigh Piccinino on Sunday, February 14, 2021

In reply to by Peter Ravnholt

Hello,
I’m still having difficulties, so maybe you can’t except attachments sent through an iCloud account? That’s where I’ve been trying to send from/everything else I send to other developers on their games works well. Here, however, I don’t know or if I can send you my screen recording. So, how can I get it to you otherwise?

Submitted by Blackadder on Monday, February 15, 2021

Any hints about fighting the king? I spoke with his lady upstairs and she told me about the tips. However I cannot beat him. I tried once with double edge sword and another with a sword and the shield. My studs are Strength 11 agility 13 stand or 25. I have magic shield and magic paralysis. Is it worth it having only one discipline in magic? How about fighting Do you only have to use chop and cut after he thrusts? How do you fight him? Help please I keep dying all the time thank you

Submitted by DMNagel on Monday, February 15, 2021

Try to get high paralysis magic, use it on the king and chop him up.

Submitted by Anthony on Tuesday, February 16, 2021

Yes I agree use paralysis magic on him and make sure you have your life high as you can from training with the trainer in the city before you go and do that part of the mission sneaking in to his part of the city then once you use for Alice is this chop them up late who was said

Submitted by Ashleigh Piccinino on Tuesday, February 16, 2021

Hello,
you should've chosen invisibility magic instead of that for a shield. you know that you can cast that only once or so, but i did it/worked as long as you also use paralysis as well. I think my stamina was AT 0 OR SOMETHING BUT MY LIFE WAS AT LIKE 17 OR SOMETHING AT THE ENd. I guess it has to do with your own personal luck as well, of course not checked in the game.

Submitted by Nam on Friday, March 5, 2021

I'm currently at a place where it reads "You are on the narrow shore of Lake Skagi, standing against a tall cliff. Further ahead, the shore disappears completely, leaving no space between the cliff and the edge of the water. There is an opening leading into a grotto here.". I chose "Go into the grotto" and there was a boat but I can't seem to be able to sail it, no matter what I tried. The other option was to "Walk back along the shore", leading back to the lake where I can go back to the White Temple or home of the Miratanians. However, there seems to be no way for me to progress further. The currently available hint says "Have you tried traveling north along the river? The city of Borgan might be an interesting place to visit".

Can anyone help me with this please?

Go back to the White Temple, then go back even further. Once you get to the river, start travelling northwards. Eventually you should get to the city.

Submitted by deebee on Wednesday, May 5, 2021

Hello,
At the cliffs by lake Skagi, I see no way to go to the city. The help says go north, but the path leads to a grotto where the only possibility is to go back to the cliffs.
I tried to go back to the lake, even to the forest.
Surely I'm missing something? but the help does not help :-)

Edit: why does this post appear twice? I did not send twice, I promise :-)

Try to go back to the shore of lake skagi. From there, go back to the white temple and try to find your way back to where you said goodbye to Egil at the river. From there, it's North all the way.

Submitted by Roxann Pollard on Sunday, May 9, 2021

I also got stuck in the same place. thanks for the help.

More Like This