I Think it's Time to Give Fleksy Another Shot

I've been following the Fleksy app and testing it with VoiceOver when new releases come out.

After playing with the latest version in the app store, I think it is worth giving Fleksy another try. I know many people were discouraged when it was released as an OS-wide keyboard in iOS 8. Yes, the app wasn't very useable with VoiceOver in the first few versions. Some of the issues were with iOS itself and some with how Fleksy was implemented.

As the Fleksy team has worked to both update the app and include new features, however, I think it has now gotten to the point where it is pretty useable with VoiceOver.

I can easily type text, delete words, choose new words, switch to the numbers and symbols keyboard and back again, etc.

Also, one can now use either the predictive typing or custom typing by moving one's finger around the screen until the desired character is spoken and then the desired character is typed after one releases one's finger.

Anyway, I think that, as they have been working hard to include features for others that will make the app more popular in the app store, they have also been slowly but surely addressing some of these accessibility problems that have popped up. So, I'd be interested to know what others think of Fleksy now. I personally think it is working pretty well.

--Pete

Forum: 

#1 Thank you

Pete, thanks for your feedback, we really appreciate it.

We're constantly working on improving Fleksy for VO users, and there's many more improvements to come.

Stay tuned!

--Kosta

#2 still not useable

I'm still fidning this app almost completely unseable with voiceover. Several things, like finding the word I want, adding a period, and overall tying are still difficult. What do I need to change, fix, etc? I have given the app full access.

#3 I'll Give It a Shot

I would love to have it working again, and will take your advice and give it a go.
I want Fleksy to work

#4 Fleksy fixed

I have given Fleksy another try and I am so pleased that it works again as well as Fleksy VO used to work. Thanks to the guys at Fleksy for continuing to improve Fleksy with VoiceOver, despite all the caustic comments. One issue I would like to report, is that when using a Bluetooth keyboard while Fleksy is the default on-screen keyboard, one experiences some problems: misspellings are not announced and the keyboard gets stuck in an area of the screen and one has to physically touch the screen in another area to get the keyboard to function in that area. But very good work, guys, I for one really appreciate it and will from now definitely use Fleksy again.

#5 Yes it's definitely better

I have also followed the Fleksy development, and i have contrary to popular views thought that it always has had great potential, however there have been rough edges that needed to be smoothed out. I'm also a beta tester and this makes the experience even more fun, i think. I don't know much about the old fleksy or the Fleksy VO app since at that time it wasn't available in Swedish which it now is, but i have a theory about why some of us think it's tricky to use Fleksy in IOs. Remember this is only part of the problem not the entire one. I have to ask the users of the old fleksy, The keyboard area was, was it not bigger than it is now? If this is the case i think that part of the problem is that we make too big gestures when we swipe up, down, left or right causing us to fall outside of the keyboard area, so therefore we have to learn to make smaller gestures, at least that is the problem with me. I tend to do big gestures and so i accidentally leave the keyboard area and the wrong word gets written. Fortunately though there have been improvements in the Fleksy app that makes me hear where the keyboard area is so i make less and less mistakes when typing. Having said this, i think that we're now nearing the point where i think i can trust using Flexy in other apps than notes and the Fleksy app itself. In other words, we're slowly but surely getting there.

#6 Space Bar

I find when typing in gestures instead of getting the bottom row of letters I hit the spacebar. The good old versions of Fleksy didn't have a spacebar as flicking right gave a space. I know it's possible to put the new fleksy into a minimal mode but then it isn't possible to swap keyboards to the Apple default. What I would really like is a "change keyboard" button on the minimal keyboard or a gesture to change to the Apple default keyboard. Sometimes a swipe up or down with three fingers adds and removes the spacebar and other buttons, but this doesn't seem to work consistently.

Well done to the Fleksy team for doing as much as they have to help us Voiceover users. Alas there's still some way to go before the new Fleksy is as easy to use as the old one was.

#7 Fleksy still doesn't work reliably with direct touch typing

Not sure if this is a problem with iOS or fleksy itself, but when direct touch typing is enabled fleksy will not register single-finger presses to the keyboard properly. I find this especially bothersome as I use direct touch exclusively. Also, as another poster said above, I would like to see a gesture to switch between keyboards so I can hide the bottom row. Other than that, great job fleksy team! I'm glad to see fleksy return to the accessible keyboard we know and love! please keep up the great work!

#8 Re: Direct touch typing with Fleksy

I don't know about using direct touch typing with Fleksy, but you can enter individual characters by using the standard input method. Just hold your finger on the keyboard until it announces a letter and then move your finger until you hear the desired letter spoken. Now when you remove your finger from the screen the desired letter will be typed.

also, if you want to remove the space bar and certain other buttons at the bottom of the screen, do a two finger swipe down on the keyboard. A two finger swipe up will restore the space bar and additional buttons.

Hope that helps.

--Pete

#9 Spacebar and size of keyboard

I think that Krister hit the nail on the head with the comments about the size of the Fleksy keyboard since iOS 8.

I too noticed that much of my earlier problems using Fleksy were coming from the fact that I was sometimes hitting or swiping areas outside of the keyboard on the screen. I was also often accidentally hitting the spacebar.

So I did some probing. I took some time to just run my finger over the Fleksy keyboard to understand where the letters and other special keys were and how big the keyboard was relative to the screen and where I was typing. It quickly became apparent that I had assumed that the keyboard was taking up a much larger area on the screen than it actually was. Maybe in older versions of Fleksy (pre iOS 8) the Fleksy keyboard was larger. I don't know.

Anyway, after learning about the layout and size of the keyboard and the fact that it was taking up less screen area than I had expected, I started typing and/or swiping within a smaller area of the screen. This dramatically improved both the accuracy of Fleksy as well as the reliability of some of the swiping actions within Fleksy to select a word, change the keyboard layout, etc. I also noticed that I was now able to keep the spacebar and other special keys visible without hitting them accidentally any more.

So my advice is, before typing, just take some time to browse the keyboard layout, size, and location on the screen. For me, this made a huge difference.

--Pete

#10 Question regarding gesture for hiding/unhiding the bottom row

How does one hide the row of buttons at the bottom and then bring them up again? I've read that the gesture for that is to perform a two finger swipe down on the keyboard area to hide the last row, and then a two finger swipe up on the keyboard area to bring them up again.
I have tried and tried, but am not having any success. The buttons stay there, no matter how many times I have tried that gesture. This makes it difficult to type and perform the relevant gestures for Fleksy in the keyboard area, since Voiceover focus keeps moving to the buttons in the bottom row. I could try the Minimal size keyboard, which hides the bottom row altogether. However, that's not a good option since that takes away the Switch Keyboard button (which is a part of the bottom row), and so, there is no way to switch to the stock iOS keyboard.
Can anyone please explain how they have gotten around making this work? Also, what size should my keyboard be for this gesture to work? I see a few options in the Fleksy app; Large, Original, Small, Minimal and Spacebar. Which one should I set it to?
Would appreciate any help.

#11 Item chooser

Can anyone confirm the following and that is: does the VO item chooser appear to be inaccessible to you as the user? I ask this because I just wanted to know if I was the only one getting this behaviour. If more detail is required then just let me know and I'll respond back to this thread. Using an iPhone five, running 8.1.3

#12 Fleksy fixed

Someone let me know how to go back and fourth with the fleksy keyboard and IOS keyboard again? with a shortcut juscture? If I can do that, I'l go for fleksy again.

Raaj.

#13 Switching Keyboards

I am not aware of a gesture to switch from the Fleksy keyboard to the standard Apple keyboard. There is a button on the bottom left of the screen that can be double tapped with one finger to switch keyboards.

--Pete

#14 Constant Voiceover feedback

Ever since updating to iOS 8.3, I have begun encountering the issue of getting voice feedback from Voiceover when I touch any key on the Fleksy keyboard. As in, Voiceover announces each letter that I tap on. Normally, Voiceover is not supposed to give feedback when tapping the letters. While tapping, all you should hear are the keyboard clicks, and when you are done typing a word and swipe to the right, then only does Voiceover read the word that is predicted by Fleksy. However, this is not the case anymore.
Prior to iOS 8.3, this problem was very intermittent and wouldn't happen too frequently. When it did occur, turning Voiceover off and then back on would normally resolve the issue and the keyboard would behave as it should with Voiceover. Now though, each tap is announced by Voiceover which makes it quite confusing and difficult to type. Is there anything that I am missing and is there any way to fix this? Or have other users begun encountering this issue too ever since updating to iOS 8.3?
I reported this to Fleksy via their Twitter account. However, as is mostly the case with all accessibility related concerns or questions directed towards the Fleksy team these days, there was no response from their end. I was also hoping that they would maybe at least address this issue in any of their updates post iOS 8.3, but that hasn't been the case. The problem persists in version 5.4 and 5.4.1 of Fleksy that have been released ever since the release of iOS 8.3.

#15 Re: Constant Voice Feedback

I have the latest version of Fleksy installed on my iPhone 6 running iOS 8.3 and do not experience this problem.

Note: If you hold your finger on the Fleksy keyboard for too long, yes, the character is echoed by VoiceOver. But this is by design and provides the user a method for typing in specific characters one at a time instead of using the predictive typing. Using this method, you hold your finger on the keyboard until you hear a character, then, while holding your finger on the display, move your finger around until you hear the desired specific character. When you release your inger, that character is typityped into the edit field.

If, on the other hand, you tap your finger quickly (rather than holding it on the display), Fleksy will work in the usual way and use predictive typing. With a quick tap like this, the characters are not echoed as you type.

Try a quicker tap of the keyboard and see if that works.

--Pete

#16 At Peter

I understand what you are saying. However, my issue is the quick tap. Not the tap and hold as you would do for manual character entry. As soon as I touch a letter, it gives me voice feedback. Was not encountering this in iOS 8.2. But ever since iOS 8.3, this has been an issue. Now, I am on an iPhone 5S. Wonder if that has something to do with it. Not really sure. Either way, it has made the app quite unusable for me all over again.
I have tried uninstalling and reinstalling the app, turning off full access and then back on...nothing seems to have resolved this.

#17 I am having exactly the same

I am having exactly the same issue as Salman. It immediately gives me voice feedback and enters the character. There is no auto correct, the only things that work for me are the flick right for space and flick left for delete. Other than that, behavior is random, and I can't even switch back to the regular onscreen keyboard without uninstalling the Fleksy app. Maybe I am missing something. I am going to editorialize a bit though and say that for an app that seemed like it would revolutionize our typing experiences as blind people, this thing has been astoundingly disappointing since the birth of iOS 8. I am about ready to tell it to go Fleksy itself LOL.

#18 I wonder...

Club AppleVis Member

To those of you who are having the keyboard feedback issue, what is your Voiceover typing set to? Is it set to characters or words or both? Could that be affecting the feedback you are getting from Fleksy? Just curious.

#19 Keyboard Settings for Fleksy

I am not experiencing the problem with keys hit on the Fleksy keyboard being echoed using iOS 8.3 on my iPhone 6.

In the VoiceOver settings, I have echo set to "Words" (rather than "Characters").

Note: I have seen that if my finger touches the screen for too long the characters are echoed individually (by design), but quickly learned that just a quick tap would work fine (ii.e., not echoing characters but only echoing words).

So, as someone else suggested, make sure your VoiceOver settings are set to echo words and not characters. Maybe that will help.

--Pete

#20 Changing the Voiceover typing

Changing the Voiceover typing echo setting to Words only does actually make Fleksy behave the way it should. As in, there is no more instant echo when tapping on any letters on the keyboard. I had mine set to Characters and Words. This is a bit of an odd situation, since I've never ever set my typing echo to Words only prior to this, and its worked fine. Definitely a bug that they'll need to resolve.
One other question that I'd like to ask is, how do you get the bottom row of buttons to appear and disappear? I like to use the minimal sized Fleksy keyboard, but that hides the bottom row and its really difficult to bring it up again. I've tried the two-finger swipe up gesture, but that is extremely unreliable and very inconsistent. I barely ever get it to work. I've tried a very quick, sharp swipe up with two fingers, but nothing happens. The keyboard stays the same. In fact, I end up typing extra characters when attempting this gesture, which is really annoying. Therefore, I'd like to know, is there a good, reliable way to unhide the row? Is there a specific part of the keyboard that I need to perform this gesture on?
How do you guys get it to work?I have similar problems when attempting to hide the row with the two-finger sharp swipe down gesture too. That doesn't work reliably either.

#21 Hi all. I myself am going to

Hi all. I myself am going to wait for an app update. I am going to explore direct touch typing and Braille screen input more thoroughly. I can get decent speed at both, though I need to get more accustomed to them. For me at least, for now, this version of Fleksy just doesn't seem to be worth the trouble.