Inaccessible edit field bug in TextEdit introduced in MacOS Catalina

Hello,

I would like to share a finding about a bug which has been introduced in macOS 10.15 Catalina and which occurs in TextEdit. I've already reported the issue to accessibility@apple.com but would like to bring the issue to awareness also here at AppleVis so that we can gather more support in resolving the issue.

Steps to reproduce the issue:

  1. Turn on VoiceOver.
  2. Using Finder, open an existing plain text file in Text Edit and move the VoiceOver cursor to the document edit field. (The issue does not occur in rich text files.)
  3. Use the arrow keys to navigate the text cursor inside the document edit field.

Expected behavior:

You should hear voiceOver reading the text as you move the text cursor in the field.

What happens instead:

No VoiceOver feedback.

Workaround to repair the issue:

Turning VoiceOver off and on again. The reading of the edit field then becomes accessible as it should be.

Kind regards

Adam

Forum: 

#1 Reproducible here, submit

Reproducible here, submit your sis diagnose to them as well.

ProductName: Mac OS X
ProductVersion: 10.15.1
BuildVersion: 19B86a

#2 Catalina 10.15.1

App Developer

I'm not experiencing this behavior in macOS 10.15.1 Developer beta 3.

#3 Got a reply from Apple

Hello,

thank you for sharing your experience. I've got a reply from apple stating they couldn't reproduce the issue. My macOS version is macOS 10.15 (build 19A602)

#4 Yep I get tha talot. Tell

Yep I get tha talot. Tell them to reference Feedback · FB7420939

#5 Using Mac OS Catalina 10.15.1

I'm not experiencing this issue in the latest update. That's a bizarre bug you're experiencing.

#6 Agreed here. I'm not

Agreed here. I'm not experiencing this issue in the latest version of catalina.

#7 What do you mean by talot?

Hello KE7ZUM,

what do you mean by getting the talot? Sorry, my English is not so good.

Kind regards

#8 I meant getting this a lot.

I meant getting this a lot. Sorry about that.

#9 So what should I do?

So what did you mean by your original comment? Did you mean that Apple had been able to reproduce the issue?

Regarding my communication with Apple, they have not been able to reproduce the issue so far.

#10 No I meant I get that unable

No I meant I get that unable to reproduce, or nothingn at all. I don't think I had a response for this issue as of yet even though I submited a sys diag when it happened.

Actualy I have not ben able to reproduce the issue ever since a few days ago but can't remember what I did to fix it besides restart my computer every day.

#11 Clean reinstall hasn't solved the issue

Hello,

I've just made a clean reinstall of macOS Catalina 15.1, and the issue still remains.

Kind regards