Help, new to VoiceOver on the Mac and something I have done has messed with keyboard behavior

App Developer

Hey there,
I am new to VoiceOver on my Macbook. So far i have learnt basic navigation. Things were going well before I did something stupid. I accidently pressed some command (which i dont really remember) which has changed the functionality of the right arrow and left arrow keys. Now when I am presing the right arrow or left arrow key alone, it is acting like I am pressing them along with the VO modifier keys.
For example, When I am in some text editor and press the right arrow or left arrow key alone to shift the pointer, instead of doing that it changes the entire keyboard the same way it does with VO + right or left arrow key.
I searched in all the settings to get rid of this problem but couldn't really find it. Please help me with this.

Forum: 

#1 QuickNav

You have turned on quick nav. This allows control using just the arrow keys as you say. Pressing left and up to scroll through navigation options and use up and down to activate whatever rotor option you have chosen. Alternatively, press left and right arrow keys together to exit quick nav mode. Hope that helps.

#2 It worked!

App Developer

Hey! Thanks a lot for the help. One more favor. Please suggest me a good text editor(screen reader optimized) for coding since i am from the developer background. FYI I have tried visual studio code but it doesn't give the voice output for what i type in the text editor. Or maybe its something that i am not aware of as its feature.

#3 Text Editor

Club AppleVis Member

It depends on what kind of development you want to do. If you want to develop apps for the Mac or iPhone/iPad, then Xcode would be good. For others, you can try Smultron or Emacs with Emacspeak. Even TextEdit can be used for some simple development.
I hope this helps. Good luck.

#4 disabling quick nav toggle

Member of the AppleVis Editorial Team

If you don't plan to use quick nav, you can disable the keyboard toggle so it doesn't come on accidentally. To do this, open Voiceover Utility and navigate to the, "Commanders," category in the table. Under the, "Quick nav," tab, deselect the, "Allow toggling of quick nav using left and right arrow keys," checkbox.

HTH