Weird Issue While Using AirPods 2 & Downcast

Hardware and Accessories

Hello all,

Alright, so recently, I upgraded my AirPods 1 with a new pair of AirPods 2, and so far, loving them. I did though run into an issue this morning while trying to listen to podcasts on my favourite app... Downcast.

So everyone is on the same page, everything on my phone is up-to-date. My iOS is at 12.2 and I'm using Downcast v2.941.6947. I currently have my left AirPod set to Skip Forward and my right AirPod set to Play/Pause.

Alright, so here's my issue. Usually, when listening to audio, if you tap on any of the AirPods, and let's use my right AirPod action of Play/Pause, if you tap once, the audio stops and if you tap again, the audio resumes. This is the case when listening to music (haven't tried this on any other type of media such as Netflix or content purchased on iTunes.

When playing podcasts from Downcast though, if I start listening and then tap to pause, the audio stops immediately and if I tap again to resume, it usually resumes fairly quickly. If I continue listening to that same podcast and let it play for several minutes and try to tap on the Play/Pause, the audio stops, but if I try to tap again to resume, it takes a long time, like 20 seconds, before it resumes. It also seems as though the longer I listen to a podcasts without pausing it, the longer the delay in resuming playback the next time I decide to pause and play.

Alright, so I hope I didn't confuse anyone, because this is a little complext to explain really.

I plan on sending an email to the developper of Downcast and to Apple in the hopes that perhaps one of them might be able to fix it on their end.

Oh, and I've tried un-pairing and re-pairing my AirPods to my phone. I've perform a hard reboot and even uninstalled and re-installed the application and the glitch is still present.

Part of me is also curious if anyone out there, with a pair of the second generation AirPods using Downcast might be encountering the same issue?

I do plan on trying to see if I can reproduce the glitch when listening to Netflix or purchased content.




Submitted by That Blind Canuck on Friday, August 16, 2019

Unfortunately, I've yet received any word back from the developer of downcast. For now, the issue bothered me so much that I just bit the bullet and switched over to Overcast.

I do miss down cast a bit as it was a lot more fully featured, compared to Overcast, but I do believe that, on the developers website, there is mention of an update in the works. When the update is available, I will re-download Downcast to see if the issue has been resolved.

Submitted by Vash Rein on Saturday, August 17, 2019

Experiencing this bug on YouTube application. It’s a long-standing bug actually
Only workaround I found on YouTube application is to go to home screen. Play pause through AirPods works normally at that point. but not when you’re actually in the application.

I would recommend emailing Apple as well. Maybe even calling Apple accessibility so that they can submit a bug report to engineers. The more people report this, The more likely it ends up being resolved.