VoiceOver won't work with bluetooth headphones.

Forum
Hardware & Accessories

I recently bought a Bluetooth headphone and the voice for VoiceOver doesn't 't come through although my audiobooks play. Is there some kind of setting I need to change? I've looked in the settings for voiceover but didn't see anything there.

I'm using both an iPhone 8 Plus and iPad 6, both running iOS 13.1.2

Thanks in advance for any suggestions!

Guy

Options

Comments

Submitted by KE7ZUM on Friday, October 18, 2019

You might need to find the accessory for said headphone. I've ben usign vo with my bt headphones and all works as expected over here. And this since iOs 13.0 in august of this year.

Submitted by Travis Roth on Monday, October 21, 2019

Club AppleVis Member

Hi,
What headset are you using?
I have noticed this with a Bose Soundwear. Media (e.g., music) plays through it, but VoiceOver does not. I toggled the "Speech channels" setting in Settings > Accessibility > VoiceOver > Audio but this did not help.
I have to assume that there is something with certain headsets and how they handle stereo that VoiceOver does not like in iOS 13 that was not an issue in iOS 12. For now I am afraid it is trial and error to find those that work.

Submitted by Guy S on Monday, October 21, 2019

In reply to by Travis Roth

Thanks Travis! I'm kind of assuming you're right about certain headphones. I just bought an Aftershox Aeroplex bone conducting set and they are my first bluetooth headphone set I've had so was/am surprised by this issue. I'll wait to see if any more respond before I break down and try another brand as these were kind of expensive!.

Submitted by Guy S on Tuesday, October 22, 2019

I tried a couple of things and found a fix for not hearing the VoiceOver through my Aftershox headphones. I turned off the VoiceOver and then powered up the headphones and then turned the VoiceOver on and was able to hear the VoiceOver voice. The volume on the rotor tool still adjusts the VoiceOver voice independently from the volume of your music, podcasts etc. I think the work-around is to have the VoiceOver off before powering up / connecting the Bluetooth headphones rather than connecting the headphones while the VoiceOver is on. Go figure....

Hope this helps!

Submitted by sockhopsinger on Tuesday, October 22, 2019

I have two pairs of truly wireless earbuds, and I have paired them with no problem. Voiceover comes through them just fine, although I do not recommend them for playing games. Even with Bluetooth 5.0, I find that there is still too much lag for consistent game play.

Submitted by KE7ZUM on Tuesday, October 22, 2019

Actually the work around is to switch to the destination option in the router and swipe down to your head phones. Try that next time.

Submitted by Guy S on Tuesday, October 22, 2019

Thanks!! I knew there must be some option, either in the settings app or maybe the rotor tool but hadn't made it that far.

Submitted by KE7ZUM on Tuesday, October 22, 2019

I found it by accident when playing with reflector on the mac and windows machines, YOu're welcome. And hope that helps a bit.

Submitted by Travis Roth on Wednesday, October 23, 2019

Club AppleVis Member

Hi,
I found the Destination in VoiceOver's Rotor settings and it is enabled on my phone. But I cannot get that option to appear when I go through the rotor options when I am on the home screen, even after I start playing audio.
Is there some specific area you must go to get Destination to be an active rotor option?

It's sounds like you have 'destinations' turned on in Setting > Accessibility > VoiceOver but not on the Home screen. VoiceOver rotor tool is specific to what screen you are on. Try the rotor tool in "Music" if you are listening to music, or in "Audible" if you are listening to an audio book. The Home screen wouldn't have an audio player on it, i.e. 'play, pause, next track' etc.

Hope this helps!

Submitted by KE7ZUM on Friday, October 25, 2019

Actually it worked for me at the home screen but that was when I was air playing to reflector. Hmm.

Submitted by Oliver Kennett on Friday, October 25, 2019

I believe that audio destination only applies to airplay and not to bluetooth.

If you go to your control centre and go to the bluetooth settings you should be able to see what is connected. Make sure it's going through your intended device.

I do not believe that there is an easy way of controlling VoiceOver output and and audio stream separately. I know that there are issues with certain speakers and devices, for example, I've got the Riva S which IOS 13 believes to be headphones, whereas it sounds like the Bose wear, instead of being treated like headphones is coming up as a bluetooth speaker.

If there is a way to independently change the origin of VoiceOver whilst using bluetooth devices I'd be very interested to hear it, but, as I understand it, there isn't.

Submitted by KE7ZUM on Friday, October 25, 2019

Ok, my head is spinning. Good point. Anyone shed some light on this, either that or it's my headache talking lol!

Submitted by Doug on Saturday, October 26, 2019

In reply to by Travis Roth

I've worked with all the updates in ios 13.x and find the bluetooth behaviour varies depending on what one is connecting. Generally speaking, I suspect that IOS 13.1.3 behaves differently depending on one is connecting speakers or headphones, both being of course Bluetooth. When I connect my JBL flip 4, whatever I've playing cones through the JBL speaker while voiceover comes through the phone. With my beats studio 3S (that was a mistaken purchase) both sources come through the headphones. I have an older Aftershokz bluetooth and on first connection, while all audio sources came through the headset, the volume was almost inaudible. I had to bring both volume on phone and headset to maximum and then back off on either for a more appropriate level. So, I suspect that some devices may have an identifier in their transmition telling the IPhone whether they are speakersor headphones. If this is indeed a new feature, I would like the option to manually modify which device gets activated when listening to any audio presentation while using voiceover. I did read about the roter setting while using voiceover. I did find a setting under accessibility/voiceover called rotor. Within Rotor, there is an on/off switch near the bottom of that long list labeled "audio destination." Even if I have this switch enabled and play music, it doesn't even show up in the rotor itself whether set to on or off. What am I missing gwentle readers?

Submitted by Oliver Kennett on Saturday, October 26, 2019

You're missing nothing. Destination only applies to airplay, and certain airplay at that. I know it's there when connected to the Apple TV

Unfortunately, we are looking for a feature that does not exist when using bluetooth.

Submitted by Blade Runner on Tuesday, October 29, 2019

For those who aren't able to get vo to speak through their headphones, I think it would be interesting to determine the values set on the device for the major and miner class or type. Primarily the miner class.
On a Mac, you can find these values as well as other information about the device in the bluetooth section of system information once the device in question has been paired. I don't use Windows, but I'm sure there is a way to access this information there as well.

Submitted by Leon on Monday, January 6, 2020

All with type headset, work as before. The one speaker, where the VO output didn't go to speaker, had a type of loudspeaker.
It would be nice to control where VO should output to.

Submitted by Eric Davis on Monday, January 6, 2020

When I have had this problem it was due to the device I was trying to connect requiring an update for it's fermware. If this wasn't the case, usually it just didn't support what I was trying to do with it. Most devices using version 4.1 or higher of bluetooth shouldn't have problems with VO. Does has a utility for the phone that can check for an update for most devices. The utility is accessible now.