Problems with Bluetooth keyboards and VoiceOver in iOS 8

I recently updated my 5th generation iPod to iOS eight. Since that time, when ever I use my Blue Tooth keyboard, I noticed A serious bug. I can use the arrow keys to move around the screen, but the letters do not show up in the text field. this is a problem in every type of text field, whether it be sending emails, messaging, or wordprocessing. I even disabled pridictive help. Then, I turn voiceover off. The letters began to appear in the text field as I typed. It seems that voiceover is interfering with my ability to use my Bluetooth keyboard. any suggestions, other then reset my iPod. That's what the Apple care technical support specialist told me to do. At that time, we did not know that voiceover was the problem. I hope someone can help me, because I would really like to be able to use my keyboard.

Forum: 

#1 tip

i have had this too. it's very anoying. the way to get around it, is to turn off quick nav, by pressing your left and right arrow keys together to type, then press it again to navigate around the system.

#2 this is well-documented

Hi. This problem is a really well-documented one, loads and loads of people are experiencing this. It's this problem alone that's keeping me from upgrading to iOS 8. Once the problem has been fixed, I'll upgrade but until then...

#3 More Bugs

Exactly, typing currently requires QuickNav to be disabled. This, however, is not the only keyboard related bug that is currently present on iOS 8 with VoiceOver. The keyboard commands to move the Voiceover cursor to the first or last element on the screen, to move between app sections (iPad only) or to scroll a page up or down are not working either. Finally, pressing Control + Option + the arrow keys with QuickNav disabled does not move the Voiceover cursor between elements.

I have decided not to upgrade my iPad to iOS 8 until Apple fixes this.

Regards!

#4 quick nav

I don't see this as an issue, but in fact is more like the Mac. When quick nav is enable, you cannot type in a text field, and now iOS appears to be going that rout.

#5 Some elaboration

Club AppleVis Member

Normally, when you activate a text field on iOS, Quick Nav is automatically disabled, but that sometimes doesn't happen, especially if a text field is automatically put into editing mode. That can trip you up if you don't catch it, so be sure VoiceOver announces Quick Nav Off before you start typing. Likewise, Quick Nav is up posed to turn itself back on when you hit Return, but that doesn't always happen either, especially if you had to disable Quick Nav manually. And yes, Quick Nav must be turned off when editing, or else a number of things won't work because of key conflicts.

With that out of the way, you will find that a great many VoiceOver commands are broken currently in iOS 8. This is why I am repeatedly saying to anyone with a Bluetooth keyboard to stay away from iOS 8 until they can get the bugs worked out. I sent to email to the Apple Accessibility team, and I mentioned my specific problems with using Bluetooth keyboards. I think I listed seven different issues, and I encountered still another issue after sending that email. Long story short, if you're using iOS 8, you may want to put away your Bluetooth keyboard and just use the touch screen for the foreseeable future.

#6 I've been having problems as

I've been having problems as well but a bit different. When I'm trying to send a message via text on my iPhone 5 now that I've gone to IOS8, once I've started typing, VO stops speaking for a second then says VO is on, and I discover I have the last letter I typed repeated many many times and I have a hard time deleting them. I too would like suggestions to avoid this.

#7 I had that too

Club AppleVis Member

I had that exact same problem with Bluetooth keyboards, one of several bugs I reported to Apple Accessibility. What I believe is happening is that VoiceOver is crashing, then relaunching, which is why you stop getting speech feedback and later hear VoiceOver On. And yes, this can cause a character to repeat itself multiple times. What's worse, I cannot use Option + Shift + Left Arrow to select the last word, because the Shift key is not recognized and no text is selected, yet another issue I reported.

Unfortunately, I am not aware of any workarounds for these issues.

#8 1 work around maybe is to

1 work around maybe is to turn on and off qn mode.

Hth.

#9 This is by design

Like a couple of the above posters, I believe this is not a bug. rather it is by design to make IOS line up with Mac. Perhaps we should stop seeing these things as bugs for bluetooth keyboards? We'll see with the next update of the Os. Whenever that might be.

#10 Thank you!!

I really appreciate all those who pointed out the QuickNav solution. This works just fine for me. Thanks again!