Logitech Bluetooth Keyboard not Working on Whatsapp after Upgrading to IOS13.1.2

Forum
Hardware & Accessories

Hi all, I'm using IPhone 6S and after upgrading my IPhone to the latest version of IOS, my logitech bluetooth keyboard isn't really compatible with Whatsapp. When I'm typing on the compost search, the shift key on my keyboard doesn't work. Therefore, I'm unable to input capital letters, question mark, et cetera.
I'd really appreciate if someone can help me with this.
Thank you

Options

Comments

Submitted by BlackCat on Friday, October 11, 2019

Hello Ruth
I'm using an Astrum 3.0 bluetooth keyboard and experience the same issue. This only happens while typing within a Whatsapp chat edit field. All other edit fields like FaceBook, Notes, Mail and Messages cause no issue. I contacted Apple Accessibility and the reply I received explained that I need to contact the developer of Astrum Bluetooth keyboards. I am using my Astrum now for 5 years and were thinking it is getting outdated. Thank goodness for your message here, because purchasing another brand will just means I'm will waist good money.

Submitted by Ruth on Saturday, October 12, 2019

So how do I solve this issue? Do I need to contact Logitech Bluetooth keyboard developer? Or should I wait for the next version of IOS to be released and see whether the problem still persist? I only face this problem within the whatsapp chat.

Submitted by Maldalain on Saturday, October 12, 2019

The same exact problem with my iClever bluetooth keyboard. It is not a problem with the keyboard, it is either Apple or WhatsApp to contact about this problem. All other edit fields including typing in Pages and other word processors, Facebook, Messenger etc, they all work fine. It is only in WhatsApp. Also I am unable to use the keyboard to perform some commands like checking the status menu. Please confirm this to me.
Thank you.

Hello
The only work around if I even can call it that, is to type in any other word processer or app for example: Messages, then select, and cut the message and paste it in Whatsapp. My thoughts: Contacting Whatsapp about this bug. If it was a hardware issue with our keyboards, we would not be able to type correctly in all other text fields on the phones.

Submitted by Ruth on Saturday, October 12, 2019

I mainly use my Bluetooth keyboard for typing. May I know what's the command to check status menu?
So, since we are not contacting apple or whatsapp, do you think this issue will be solved in the next release of the IOS?

Submitted by BlackCat on Saturday, October 12, 2019

In reply to by Ruth

Hello Ruth
I Submitted feedback to Whatsapp. Control plus Options plus the Letter M takes you to the status bar, but unfortunately this set of commands only works when inside any app. Not on the home screens like before. This particular one is a Apple bug for sure.

Submitted by Kris on Saturday, October 12, 2019

I have been having this problem too since updating to IOS13. All other edit fields work just fine with my Logitech.

I sent feedback to Whatsapp about this problem. Their reaction was that everything to do with the keyboard is controlled by IOS. I refuted this by telling them that the only place I can’t use the question mark or the exclamation mark is in Whatsapp. They say that their developers are looking at the problem.

Unfortunately, I haven’t heard anything from them since.

Submitted by Ruth on Saturday, October 12, 2019

Do let me know once you have heard from the developer.
May I know where is the option key for Logitech?

Submitted by R on Thursday, October 17, 2019

Cursor in the input field of Whatsapp:
1. Press "alt" or "cmd" (keep holding)
2. Press "Shift" (keep holding)
3. Release "alt" or "cmd"
4. Then type the key(s) you expect to be "shift".

Stupid enough rite ? hahaaa...

Submitted by Kris on Thursday, October 17, 2019

In reply to by R

Hello R.,

Unfortunately, this doesn’t seem to work for me. When I hold down the alt, then the shift and release alt and press the slash, all I get is the slash and not the question mark I need.

Do you have any other ideas.?

Submitted by KE7ZUM on Thursday, October 17, 2019

I can reproduce this on my corser machanical wireless keyboard so this is not a logitech issue but a what's app issue. By the way your fix didn't work either for me.

Submitted by KE7ZUM on Friday, October 18, 2019

You can contact them through the app. But good luck as they really do not respond, and when they do they really don't know what they are talking about.

Submitted by Val on Monday, October 28, 2019

I'm using the Microsoft flodable bluetooth keyboard and Logitech bluetooth keyboard. I noticed that I'm not able to type in the punctuation marks when you hit shift + number. I also noticed that shift + letter does not type the uppercase letter. I always have to hit Caps Lock just to enter an uppercase letter. This happens on both brands of bluetooth keyboard in Whatsapp only so this is not related to the keyboard brand itself nor iOS because both keyboards work perfectly in Facebook, Instagram and emails. This is specific to Whatsapp.

I tried the interim solution proposed at #10 and it works! Thanks!

Submitted by KE7ZUM on Monday, October 28, 2019

10's solution did not work for me at all. And I'm surprised contaacting what's app has not yielded a fix as of yet.

Submitted by mkuse on Monday, October 28, 2019

Hallelejah, just updated to WhatsApp 2.19.110 and it is FIXED... They didn't mention the Fix it in the Changelog, tststs....

Submitted by KE7ZUM on Wednesday, October 30, 2019

Really? Someone else said it was resolved as well withthe new what's app update. I'm getting my bt keyboard repaired so cannot test, but ther you go.

Submitted by KE7ZUM on Wednesday, October 30, 2019

If it is an app you developed you will need to probably contact what's app and ask how they fixed it so you can fix it in your own app. If this is what's app then update. It is according to my friend fixed. Again I can't test as my bt keyboard is in the shop.

Submitted by KE7ZUM on Thursday, October 31, 2019

Yep, that makes sence. And that is actually true in most apps. ON the mac that would be option enter.

Submitted by Sharon O on Sunday, November 3, 2019

In reply to by R

Thank you R for giving an interim solution to the very annoying Bug from the latest IOS update. I have been typing, copying and pasting from Notes into Whatsapp which is sooooooo time consuming. I’ve got other keys that don’t function properly but tend to find the solution is to press opposite key. Thanks again :)

Submitted by Ruth on Monday, November 4, 2019

Another issue I'm having now is while typing on Whatsapp, pressing enter will send the message without my permission. Pressing alt + enter doesn't work for me if I want to go to the next line. so what is another alternative to create a new line? Thanks

Submitted by KE7ZUM on Monday, November 4, 2019

I actually thought it was control enter, or am I gettingmixed up here which could happen. I'm exhausted.

Submitted by KE7ZUM on Tuesday, November 5, 2019

I can also confirm the fix. My k63 came back from beeing repaired and now the keyboard thign is fixed. So is the alt enter for the CR.

Submitted by KE7ZUM on Wednesday, November 6, 2019

Odd. I tried alt plus enter and it works. I wonder why yours is different. It always has ben alt enter at least on the mac side of things, option enter if you will.