Help, Logitech K780 QuickNav commands not working

Forum
Hardware & Accessories

Hello,

I have been lurking here for about two weeks. What a wonderful resource.

I recently purchased a Logitech K780 multi-device keyboard. It is connected to 2 PCs, and my iPhone. The manual says to press tthe "Fn" key and the letter "i" on the keyboard to configure the keyboard for IOS, and the "p" key for PCs. Then I open Safari, and try the quick-nav key commands like "H' for headings and so on. Nothing. The rotor commands work find, the quick-nav announces that it is indeed turned on, but nothing from any of the keyboard commands for browsing safari. Some additional commands also do not work. The Cmd-Tab key which is supposed to change the active application to the next app does nothing as well.

Any help will be greatly appreciated.

The Venerable Karma Konchog Jungney
A deaf-blind Tibetan monk

Options

Comments

Submitted by falcon wings on Saturday, June 10, 2017

Did you actually turn the quick nav keys with the caps lock plus Q shortcut first?
at least I remember it as Q something. if the capslock doesn't work out.

the command tab has never worked for me, using a logitech k380,does nothing,as far as I know.

Submitted by Konchog on Saturday, June 10, 2017

In reply to by falcon wings

I did not change my voiceover key combination to include the capslock key. So the correct statement of the toggle command is VO+Q, which for me is Control+Option+Q. I am still trying to find a description of this command, as there are perhaps other commands I am not aware of.

Thanks for the help. Also Cmd+tab still does not work. However, I can still get to the app switcher by pressing VO+H twice quickly.

konchog

Submitted by Brian Giles on Saturday, June 10, 2017

Cmd tab is only on the iPad for now. I really hope they bring all the keyboard comands to the iPhone.