Strange issue with my braille display and iOS12

Forum
Braille on Apple Products

Hey guys,
So on my iPhone I am using my BrailleSense Polaris as a braille display.
But lately, and I don't know if it's just happening to me here, some labels aren't showing up, specifically form controls.
If I go to say a text field or search field, VoiceOver's speech is the only one that reads the label of it. Where as braille only displays txt field.
This also happens with checkboxes and radio buttons. No label. It's just rd btn not checked sign, and rd btn checked sign.
If I'm the only one having this issue, then maybe I should switch braille displays.
I've already tried contacting Apple through the beta Feedback app to get it fixed in later versions, but they've not done anything about it, at least, not that I've seen.
Sorry for the long post, and hopefully this issue can be resolved if it's not only me in the ditch.
Thanks!
Tunmi

Options

Comments

Submitted by tunmi13 on Thursday, November 15, 2018

Hey guys,
So it seems some search fields are being spoken and outputted to the display, while others are only spoken.
Thanks!

Submitted by Eric Davis on Saturday, November 17, 2018

If this is just when you are on the web, it could be a matter of the way the sight is coded. Just a guess on my part.

Submitted by tunmi13 on Saturday, November 17, 2018

Well see, that was what I thought. Until I tried
AppleVis and it wasn't reading the checkboxes or radio buttons either.
VoiceOver speaks them, but doesn't output to the braille display.
From the braille perspective it's as if the element is not labeled.
And it's not just on the web, it's everywhere.