Problems entering text with a braille display

Member of the AppleVis Blog Team
Forum
Braille on Apple Products

Hi everyone. I have a HumanWare Brailliant BI40X. When I got it, I was shown how to use it with an iPhone, including entering text. I exchanged text messages with my trainer. I know it worked, last October.

Since then, I've primarily been using the display to read NLS books. In other words, I've been using it as a standalone device, not with my iPhone. But now I want to get up to speed on using it with my iPhone. AppleVis and the Apple documentation have been great, except for one problem.

I can't seem to enter text in a text field. For example, I open the Messages app, select a conversation, and navigate to the text field. I select that text field (either with one of the cursor routing keys, or with Space+dots 3 and 6. But when I start typing, the characters appear for a moment, then vanish. If I type a word quickly, it vanishes immediately after I hit the spacebar. After I've typed my entire message, there's nothing but spaces, and I verified this by hitting backspace - all I hear is "space, space, space" for each character I delete.

I did a cursory search of AppleVis for a problem like this, but came up empty. Anyone know what I might be doing wrong? I figure it has to be something obvious, because, as I said, I know this worked months ago when I first got the display.

Thanks for any help.

Options

Comments

Submitted by PaulMartz on Saturday, May 14, 2022

Member of the AppleVis Blog Team

The Braille characters I enter show up just fine on the Braille display for a few seconds, then vanish. Or they vanish as soon as I complete a word and hit the spacebar. Either way, the text field on the iPhone is empty except for spaces.

I've got my blind tech trainer trying to figure this out, and he's stumped too. Next week I'll be at the Colorado Center for the Blind, maybe someone there can help.

Submitted by PaulMartz on Saturday, May 14, 2022

Member of the AppleVis Blog Team

I switched the table to English, Unified, System, and it works fine now. Thanks for that tip.

Documentation for these tables appears to be non-existent. As someone who's relatively new to Braille displays, I have no idea what the tables are, or why I would want one instead of the other. But it seems like they should all allow input, shouldn't they?