Google Docs Braille Typing Feedback Problem

Forum
Braille on Apple Products

I work with multiple students with iPads and refreshable braille displays. I am having a problem with the Google Docs app on the iPad. When text is entered via a braille display, only the last letter of whatever word is entered is announced by VoiceOver. When any text is deleted, it only says "selection deleted" instead of giving an indication of what was deleted to keep the person oriented. The OS and app are both fully up-to-date. I have had this same problem on multiple iPads, with multiple Google accounts, and with different models of braille displays. I have tried with and without automatic braille translation and with various VoiceOver typing feedback settings. I do not have this problem with any other apps, including other word processors. Furthermore, parts of the Google Docs app don't have the problem, such as the file name, but the main document body does. I have also tried different rotor settings in case that was somehow having an impact. The weirdest thing is that when I turn off all VO typing feedback and it doesn't give feedback in other apps, it will still say the last letter of each word that is typed. Thanks for any help you can give.

Options

Comments

Submitted by Sasha Stride on Thursday, July 27, 2017

"Unfortunately Google documents isn't very blind or visually impaired friendly accessible according to my experience with it. It does this and I have found no way to change that.

Submitted by Anna Beige on Friday, July 28, 2017

I use Google Docs on my iPhone with my Refreshabraille 18, and I don't have that problem.
One of the settings I turned on on my PC on the Google Docs website was braille display support, which helped with some problems I was having with Google Docs on the PC. That shouldn't affect the iOS app, though. You can try to change the setting, though, if you have access to a computer.
It was in the accessibility menu while you're in a Google Document, I can't remember the exact wording of the setting, but it said something about braille. If you're on Windows, do alt-shift-f if you're using Firefox, and right or left arrow until you get to the accessibility menu, then up or down arrow until you find the correct setting.
I do have the 'selection deleted' problem, though. I just check on the display to see which characters have been deleted. Something I've also noticed is if you have speech turned on while you're typing with your display on iOS, it says when it changes a ' to a "right single quotation mark" and a quotation mark to a double quotation mark.
Other than that, though, I don't have any accessibility issues with the app. I'm running iOS 10.3.3 on an iPhone 6.
I'm not sure if this will help you, but I hope it does.

Thank you both very much for your input. Sometimes it helps just to know I'm not the only person having this problem or it's not just some simple setting that's wrong. I did try changing the Google Docs settings on the computer as a shot in the dark, but that didn't impact it. The settings menu specifically says that it's for web only. I also tried to see if I could just get the iPhone version since it sounds like some people may have fewer problems with that, but it still didn't work. I submitted a comment about the issue to the Google Accessibility Team.