Twitterrific on Apple Watch, am I just crazy, or is there a trick to this?

watchOS & Apple Watch Apps

OK, either I'm just really stupid, or there's something incredibly obvious I'm missing. I'm using Twitterrific 5 on my Apple Watch series 3 42mm. When I open the app, I'm immediately taken to the page which seems to be consisting in the top left corner of the screen, an item that just simply says Twitterrific, although double tapping it doesn't seem to do anything. The top right corner is seeming to show my clock. Then the whole rest of the screen is showing my mentions. I'm saying people who've mentioned me. It's not my home timeline though. I've tried two finger flicking left and right, double tapping that Twitterrific item, double tapping that clock item, scrolling with two fingers up and down through the 4 pages it clames I have showing of mentions, etc. I've even tried 3D touching, but all I get there is new tweet, and refresh, and the only way I see to get out of the 3D touch screen is either to choose one of those to, or press the digital crown. I used to know how to do this, but no matter what the heck I try, I cannot seem to get the dad blamed dumb bunny to switch between my buffers like mentions, home, DM's, etc. I know I've gotten public tweets in my home buffer from people I follow since those messages come in. Plus, on the iPhone, I've turned off unified timeline, as I prefer having the buffer tabs on the phone go horizontally across the top of the screen where I can have each buffer separated into its own timeline. I wouldn't think that would be effecting the watch app though, would it? So, yeah, what gives? What the hell am I missing? Pardon my language, but this is just cockeyed!



Submitted by Blinky X on Sunday, June 10, 2018

What’s up Wax, (cool name by the way). Here’s what I think you should try. First, have you purchased the notifications add on for Twitteriffic? If not, that’s your problem. If you did, then clear the cache in your profile. You might also try single tapping and holding on the app in the Apple Watch which will give you the option of refreshing the app. Hope that helps. Peace.

Submitted by Will on Sunday, June 10, 2018

hi all, i can receive dms etc. from twitteriffic on my watch, yet when i load the app on watch just see refresh but no content?

Submitted by Chris Gilland on Sunday, June 10, 2018

Actually, my name up here isn't Wax. It's WaxhawLover. The name of the city I live in is Waxhaw, and I love it, so... um... yeah... Anyway, to answer your question, yes. I've purchased the notifications addon. You're not fully understanding, I don't think, what my question is. It's not a matter of me not receiving push notifications. I'm not entirely sure where you are getting that impression.

The problem is that when I load the app on my watch, I only am seeing tweets of people who mention me. So, instead of being able to see my "Home" timeline of all tweets from all users I follow, I only see my mentions buffer, and that's it. Further, again, I've tried everything under the sun to scroll, on the watch, between the various different buffers. Again as stated in my first initial post, just to reitterate: I've tried double tapping the top of the screen that says Twitterrific, I've tried scrolling through all 4 pages of the mentions it shows by flicking both up and flicking down with two fingers. Neither direction is doing anything more than scrolling the mentions buffer. No tabs anywhere to flip flop between buffers. I've 3D touched on the screen, or as some call it, force touching, which simply gives options to compose a tweet, or refresh. Well, obviously, refreshing isn't going to help, as I'm not trying to refresh my mentions. I'm trying to get over to my other buffers. I've tried flicking left and right with two fingers, I've tried turning off Voiceover and flicking left and right with one finger, which does absolutely nothing at all. I've hit my side dock button, flicked to the app, flicked down with one finger to remove, double tapped, then went back in the watch and relaunched the app, no good. I've uninstalled and reinstalled both the iOS app, and the watch app, no good. I've gone into settings for the app on the iPhone, and have enabled streaming over wifi, and also have toggled on and off both, unified timeline, which neither state did any good. I'm totally totally out of options.

So yeah, again. Notifications aren't the issue. I'm getting notifications just fine within the watch app, and also within the watche's notification area. I just can't seem to swype, on the watch between my different timeline buffers. Hopefully that makes more sense.

Submitted by AnonyMouse on Sunday, June 10, 2018

Member of the AppleVis Editorial Team

Hey waxhawlover,

To my understanding and probably not what you want to hear but the Twitterrific for your Apple Watch is limited. The Twitterrific watch app only displays a list of your most recent 25 replies, mentions, direct messages, favs, RT’s and new followers.

That is my understanding.


Submitted by Blinky X on Monday, June 11, 2018

Now I get ya. Unfortunately, as Annonymouse mentioned, “Twitteriffic” does not offer this functionality on the Apple Watch.

Submitted by AnonyMouse on Monday, June 11, 2018

Member of the AppleVis Editorial Team

In reply to by Chris Gilland

Hey waxhawlover,

Well, this is only a guess on my part. As I have nothing to confirm this to you, but I'd imagine there isn't a whole lot of us using an Apple watch and if so you are now only going to narrow that eve more as they have Tweetings. If they do they may just don't simply visit AppleVis as often as you may like.

Unfortunately, I don't use Tweetings nor do I have Tweetings. So, I am unable to answer that question for you. As you say if someone with sight was unable to use that button as you pointed out. It sounds like I would report this to the developer and that is about all we can do. Yes, I know that wasn't much in the way of help but if you have any more questions regarding your Apple Watch or Twitterific. You know where to come! ;)

Submitted by Chris Gilland on Wednesday, June 13, 2018

In reply to by AnonyMouse

I'm not sure where in the world you got the impression that very few of us use apple watches. Actually, I know of a ton of blind users who're actually for the most part users up here that own Apple Watches, and use them practically daily. So, with all due respect, please don't assume.

Submitted by Blinky X on Thursday, June 14, 2018

I must admit that I was somewhat intrigued by this question and therefore would like to offer a possible workaround. At first, I was going to recommend the “Overcl0ck” jailbreak for the Apple Watch, but since therre’s no Cydia included, understand that if the person using it isn’t a developer the process might be a bit labor intensive. So, I got to thinking that since “Workflow” is available on the Apple Watch, that you might be able to spin up a script that might meet your needs. Admittedly I haven’t checked to confirm this, but it’s worth giving it a try if youhaven’t done so already.