Two frustrating Safari VO bugs. Anyone else?

Hi there! Since getting my first Mac last year, there has always been 2 bugs that's kind of frustrating while browsing the web in Safari with VO, and I have yet to find a solution to them. Of course there's more than these 2, but they have all been mentioned before, so I wont bother you with repeating it once more here... :) The first is when opening a new website, the VO focus doesn't always automatically interact with the html-content. So I'll have to find the place where it says html-content and interact with it to get into the actual content of the website. Then again, if doing VO+Space on a link on that site, VO focus again jumps up to somewhere in the toolbar or bookmarks, so I again will have to interact with html-content. I've contacted accessibility@apple.com about this issue, but they couldn't find a solution, and stated that it worked fine on their Macs. They asked me to test if the issue still existed when I was logged into another Wifi Network, and indeed it was. Anyone else experiencing this, and if yes, have you found a fix for it? My guess is that this happens when the website doesn't fully load. Because when I hear the VO sound that tells me that the site has fully loaded, the VO focus usually is correctly placed at the upper left corner of the html-content. But sometimes, that sound will never come, and that's when I'll have to interact with the html-content. The second thing, is when starting to browse a new website with right and left arrows, with QuickNav turned on. VO then often just reads a bunch of gibberish, like "Resultdetails", "long non-sence-numbers" and weird links. But if hitting the tab-key a few times or VO+right, then everythings back to normal again, and the content is read as you'd expect. I find this more often happens when opening a link from the results page of a google search, but it happens other places too. I wouldn't be surprised if this also happens when the page stops loading. Sighted friends has also confirmed that websites often stops loading at aproximately 90 %, and I'm not sure why this happens. Seems like a reboot of the Mac fixes this for a while, but only for a while, and it's back to haunt me and give me interacting headaches again... Hehe... :) Sorry for a too long post as usual! Lol :) Just currious if others are seeing the same issues as me, and if someone has found a way around it... Afraid the "page-stops-loading" thing could be a symptom of some other errors that I haven't found yet, but it's still weird that VO won't interact with the website, even though all content seems to be there when interacting... Well, I'll stop now! Haha... Thanks in advance for your always so helpfull feedback! You guys are awesome! ;)

Forum: 

#1 voiceover

I can't help you with the second bug, but as far as the first one goes, I don't think voiceover was designed to automatically interact with the html content. I think you're supposed to do that yourself. So, I think this is a feature, not a bug. I don't know this from a personal experience, because I haven't gotten my mac yet, but I've done a lot of research and listened to a lot of podcasts on the mac. In all of the demonstrations I've listened to, the user had to interact with the html content themselves.

#2 VO: Interacting with HTML content.

I have only had my Mac since May 9, but I can tell you that for the most part, I don't have to interact with HTML content. It is done automatically. Lately though, I have noticed the same behavior you have described, Cliff. My Mac Mini has a few VO quirks, especially after it has waked up after a sleep. Your tab key will quickly take you to the HTML content when this bug pops up hiss little head.

#3 Hello all, First let me say

Hello all, First let me say that I posted regarding this exact same issue about 3 weeks ago. Cliff, you mentioned that you have issues with google searches when you encounter this bug... I find that google searches are virtually impossible when this bug is active. Lisa: When using Safari VO is supposed to automatically interact with the HTML content. I have had my Macbook Pro since December and this bug has only become a serous issue since the most recent update to Mountain Lion (which included both Voiceover and Safari updates). I'm getting the feeling that this bug is pretty wide spread. Every visually impaired mac user (I have spoken with) who is running the latest version of OS X has agreed that they are experiencing some version of this bug. The fact that you are hearing people having to manually interact with HTML content in podcasts may be a further indicator of this bug's prevalence. I've even encountered it while using a Macbook Pro with a 15 inch retina display while waiting for my iPhone to be replaced at an Apple store. In fact, it was the first thing I encountered when I opened Safari. VO did not interact with any web page I tried and I was also able to reproduce the google sluggishness that is synonymous with this bug. Sandy: The most recent update to Mountain Lion was released in June so that's probably why this bug has only recently become an issue for you. I am in the same boat. Having said all of this... I have found the best solution (albeit temporary for now, and with out having to reboot your Mac) is to reset Safari. To do this navigate to the menubar with VO M, and navigate to the Safari menu. Navigate down to "reset Safari" and VO space on it. After this you will be presented with a list of things you would like to reset. In order for this bug to properly be corrected (again, temporarily) certain items need to be checked. I have found the best combination is to have every thing unchecked accept for the following items. Remove all webpage preview images, Reset all location warnings, and reset all website notification warnings. One item that I have had unchecked but might consider checking is "remove all website data". The next time I need to reset Safari i will check this item and let you guys know if it extends the fix or if it continues to be temporary. Although, if I remember correctly when I performed the Safari reset on the computer at the Apple store every one of the items in the checklist was selected, and after quitting Safari and exploring the finder a bit, the bug showed up again in my very next browsing session, so I don't know if checking this item will have any effect.. I too have been in contact with apple accessibility about this issue and they seam pretty persistent in their thinking that this is not a VO/Safari bug. They seam to think that Flash content may be responsible for this strange behavior. They have not completely dismissed my inquiry, however, and have encouraged me to reproduce the bug under no flash conditions, take notes on the steps that lead up to the occurrence of the bug, and send them screenshots when the bug is encountered. I would encourage anyone experiencing this bug to email Apple Accessibility and remind them of how widespread it is. I'll let you all know anything else I find out. Be well, Blue Orb.

#4 update and relieving news!

Greetings everyone, As I mentioned in my last post I have been emailing back and forth with Apple Accessibility about this strange Safari + voiceover Behavior for the past couple of weeks. I am happy to report that they have been able to reproduce the bug on their computers and have sent a report about it to the appropriate people. (This even includes the occurrence of google acting strangely when the bug is active.) They also tell me that they are very confident that this bug will not be an issue in the next big release of OS X (Mavericks) although they could not tell me why. For anyone looking for instructions on how to temporarily fix this bug when encountering it, please see my previous post in this thread. The good folks at Apple accessibility also noticed a seaming correlation between the bug's occurrence and how one clicks on Safari to launch it. They say that assuming you are accessing Safari from the doc, a brisk double click (with Vo plus spacebar) more reliably causes VO to behave normally and automatically interact with HTML content. A long held VO plus spacebar works similarly. A brisk single click tends to be associated with the occurrence of this bug. Be Well, The Blue Orb

#5 Suggestion to Help Fix These Bugs

Club AppleVis Member

Hello everyone, If you go to www.webkit.org and download the latest nightly build of the web rendering engine, it seems to fix most of these issues. I hesitate to say that it fixes the interacting bug completely but I can say that it decreases the issue drastically. Also, the Google issue seems to be fixed, too. Just mount the dmg image and place the webkit.app file in your applications folder. It will launch Safari with all of your current settings intact; the only difference is the web rendering engine. I set my keyboard commander shortcut right command+S to launch this. Do keep in mind that this is a nightly development build; therefore, as is with any development code, other bugs could be introduced. The program will ask you to update daily but this is not necessary. I only do it when I feel like it. Hope this helps people. -Rob

#6 This Only Seems to Happen on my Mac

Hello everyone. Thought I had replied here previously but oh well. This only seems to happen on my Mac, both with Safari and Google Chrome. I've been helping a sister learn her Mac, which she got last Sunday. We both have Mac Book Airs, her's is an 11-inch and mine a 13-inch. Just this afternoon when I was showing her Safari we went to 2 different websites, one of them being this site. She doesn't seem to have this bug, if in fact it is a bug at all. Safari is the only web browser on her computer. Very interesting.

#7 Forgot to Mention...

I forgot to mention in my previous comment here that this sister is also a Voiceover user. She seems to have a couple other issues on her machine, not related to browsing the Internet.