Sorting numbered table in pages?

Hi,
I do a chart show on a radio station, which requires me to take votes from listeners for various tracks. I put this data in a table with the track artist, title and the number of votes. So far I've been doing this on windows and used the sort option so that the tracks in the table are ordered according to the number of votes for each track. But now I switched over to a mac I'm not sure how to do this in pages. Does anyone know how this could be done, or if it's not possible, what's a better alternative?

Forum: 

#1 RE: Sorting numbered table in pages?

Hello Hubert,

The following instructions apply to the current version of Pages (5.2.2) under OS 10.9.4.

1. Interact with the table you wish to sort.
2. Press VO+SHift+\
This pops up a menu which enables VO Users to move focus to the table’s reference tabs. On my system there is no audible indication when this menu pops up, but when I press the down arrow I find choices for “Column reference tab” and “Row reference tab."
3. Assuming you want to sort by column, Press Return on “column reference tab." VO moves focus to the reference tab for the current column and announces, “”header name, reference tab.”
4. Press VO+right or left arrow to move to the reference tab for the column on which you wish to sort.
5. Press VO+Shift+M to popup the shorcut menu, then arrow down and you will find menu choices to sort ascending and descending.
6. When the sort is complete, press VO+Shift+\ again to return VO focus to the body of the table.

HTH,
Bryan

#2 Referring to previous instructions

Hi,
Thank you for your advice. I've tried what you said and it worked. However, there's something that is causing me a problem.
When the votes are sorted, they are not in the order I want them to be. For example:
7, 71, 8, 81, 9, 91
This is not the right order these votes should be in. The order I was hoping for would be: 7. 8, 9, 71, 81, 91.
Is there anyway this order can be achieved, or is this the way that pages just sorts text within tables.

#3 Data format and sort order

Hello Hubert,

That sounds like it might be caused by the data format assigned to the column. Perhaps try changing the format of that column from text to numbers or automatic. This can be done as follows:

1. Interact with the table.
2. Select the column that is not sorting correctly.
3. Press Control+Option+i to open the Inspector / Formatter.
4. Press VO+j to move VO focus to the Formatter.
5. Select the “Cell” readio button and interact with the cell formatter area.
6. Actibate the Data Format picker and select the desired format.

Another thought — Have you considered using Numbers (Apple’s spreadsheet app) to handle this task?

HTH,
Bryan