Return, new line when reading in Text Edit

I've noticed that when reading a document in Text Edit, regardless of whether you read by line, paragraph, or Control Option A or B, Voiceover announces two carriage returns as return, new line, every time it encounters them. This is annoying when reading for pleasure, as it occurs before the start of every paragraph. Do other word processors, such as Pages, behave the same way as well? Might be useful to know before I pay $20 and buy Pages.

Forum: 

#1 Why this happens

Hi, This isn't a complete answer, but I can at least explain why this is happening in TextEdit. It has to do with some technical details of how files are saved on windows Systems versus macs. If you write a TextEdit file yourself, you will see that the two presses of the return key are just announced as "newline." The issue at hand is that return and newline are two separate characters, and your Windows programs don't announce that when you hit the Return key on Windows, you're actually putting in both characters. The Mac OS is being correct in announcing them separately, although it might be a little bit verbose. In short, I don't think that any other Word processor is worth buying just for this, although they are certainly for more serious applications. All the best, Zack.

#2 I was just curious if this

I was just curious if this behavior with Voiceover occurs regardless of the word processor you are running, or if it is more pleasurable reading in Pages or another program versus Text Edit if return, new line isn't announced at the beginning of each paragraph.

#3 There are several free

There are several free editors for the mac and I really don't know if they all behave the same way. It does seem to be only with windows files. Maybe do a search and replace and get rid of one of the line feeds or carriage returns. I was just trying to replicate this so I could check the file with pages but can't get textedit to do it just now. If you have a file or something to send me that does this behavior I'd be happy to see what happens with it. Feel free to email me privately if you want to send something to test. Jim

#4 I know that you can eliminate

I know that you can eliminate the return, new line message by go into Text Edit, type command F for Find, type Option Enter, check the replace checkbox, go to the replace field and type Delete, hit the replace all button, and then hit Done. However, when viewing the file in Windows, this eliminates all carriage returns. I'm not sure if this is just a feature I will have to live with when using a Mac, there's something else I can try, or another word processor behaves differently from Text Edit.

#5 Chad! I wonder if you could

Chad! I wonder if you could add something to the dictionary to ignore every time voiceover sees a carriage return and a line feed. then maybe make an activity for textedit. Not sure if this would work but it might interesting to try it. Jim

#6 I think this happens in Itext

I think this happens in Itext express as well. I've heard it do the return new line thing and what you describe makes sense as I work in unicode utf8 as I do work with cross platform stuff.

#7 I went into the Voiceover

I went into the Voiceover utilities, then went to speech and pronounciation, typed Option plus Enter in the first field, then two spaces in the replace field, checked for all applications, then clicked Add and Done. Now Voiceover only says Return when encountering two carriage returns instead of Return, new line. My guess is that if I knew what the line feed character was, I could add that to Option plus Enter in the first field and Voiceover would no longer announce each paragraph, but read continuously.