enabling TLS and SSL protocols on iphone in ios 7

Forum
Other Apple Chat
Hi all I upgraded to the dreaded IOS 7 a while ago. Now it seems I cannot access my banking application any more and the problem seems to be that I need to enable TLS and SSL protocols on the iphone. I looked under settings safari but I cannot find a setting to do this anywhere. The services I use definitely allows for this as I have worked with this specific banking application before. Can anyone help here please? Thanx and regards Andre

Options

Comments

Submitted by StarNoble on Wednesday, November 6, 2013

Hello, Just thought I would put in my two cents here, though I'm afraid it won't help your problem. I'm afraid that, IOS apps are, as a rule, what is called sand boxed. In other words, most things that the developer wants an app to have, they have to include it in their app. No other apps have access to it. The reason why I say this is that, I don't know what banking app you are trying to use, but mine works just fine. Loads of apps use TLS and SSL in IOS 7, the App Store and iTunes included, as well as other apps such as PayPal, eBay, Amazon Mobile, Audible, Bard Mobile, and the list goes on and on. As well as various web browser apps have it in them as well. So it is not a problem with IOS 7 specifically, but rather, the developer of your app needs to make whatever change they have to to make it compatible with the changes that were made in IOS 7. Sorry this doesn't help, but it's all up to the developer of your banking app to fix it.

Hi! The problem is not with the specific app as many people I know are using it on their iphones with ios 7 without any problems. The problem is with my iphone specifically and it must have something to do with secure connections also. Another interesting thing also if \I use it as a hotspot \I am not able to access any ftp sites at all. Wonder if the problems are related? Andre

Submitted by Roland on Wednesday, November 6, 2013

SSL connections usually use port 443. Do you have this problem with both, WLAN and GSM/3g or only with either access method? Is there some odd proxy setting enabled for your network? Normallly outgoing traffic on 443 should be open, just like port 80 for http. Hope this helps narrowing down the problem. /Roland