Anyone having problems syncing music from computer to phone?

Forum
Other Apple Chat

Since IOS 8.4 and the newest iTunes version I havent been able to sync music to my phone. Ive tried everything I can think of and even had someone who can see help and nothing worked. Im using Jaws 16 with the newest version of iTunes. Any help is appreciated.

Options

Comments

Submitted by Niall Gallagher on Monday, August 3, 2015

Member of the AppleVis Blog Team

Hi MsHollyWeezy,

My experience is slightly different as I am using VoiceOver on the Mac.
However, when I was using Apple Music and iCloud Music Library, the music sync view in iTunes completely changed.

The music sync changed from the standard check box, to a view that stated:
You are using iCloud Music Library, and your music will sync across devices automatically.

My iPhone was syncing with my Mac, but it was doing it behind the scenes, and I had no control over it.
In my scenario, I turned off Apple Music and iCloud Music Library, and the standard sync view and process returned.

Sorry if this doesn't make much sense, but I don't use iTunes on Windows.

Kind regards,

Niall

Submitted by Jason on Monday, August 3, 2015

I am using Jaws 16 and IPhone 6 with ios 8.4 to my music with the latest ITunes version. You still can sync your music with the latest ITunes version. It is still the same way you sync with the old ITunes version. I don't see anything change about that. Good luck!

Submitted by Jeff on Monday, August 3, 2015

As Niall Gallagher indicated, it sounds like you have Apple Music turned on. You can enable iCloud Music Library along with Apple Music to make your entire music library available across all your devices through Apple Music. Otherwise, turn these off and you should see the normal library behavior return.

Remember, just turning off Apple Music in iTunes does not cancel your subscription. If you've enabled Apple Music, you need to cancel your subscription if you don't intend to keep using it after the free trial period.

Submitted by dvdmth on Tuesday, August 4, 2015

Club AppleVis Member

You cannot use iTunes to manage music on your iOS device if you have iCloud Music Library turned on. The idea of iCloud Music Library is that your entire music collection is in the cloud, making it available across all your devices without needing to transfer songs to the device through iTunes. That is the idea, anyway, and if the service worked reliably, I would gladly use it. But I've had nothing but problems trying to use the iCloud library over the past month, and I eventually disabled it. Syncing through iTunes, though not as convenient, has been far more reliable for me.

To disable iCloud Music Library, under Settings, go to Music, then turn off the switch for iCloud Music Library. You can still use Apple Music if you like, but make sure the iCloud library is off. In my experience, the switch has a tendency to revert back to on afterward, so I recommend turning it off while your device is connected to your computer. After turning it off, performing a sync in iTunes, and the options to sync music should reappear in iTunes after the sync is completed.

One major disadvantage to turning off iCloud Music Library is that you cannot add songs to your library that came from Apple Music. Only purchased songs, or songs imported from other sources, can be added to your device. You will get an error if you try to add an Apple Music track, either from the Music app itself or through iTunes. If you don't use Apple Music, then this is no big deal, but if you do, this essentially means your personal music collection is completely segregated from Apple Music, so you cannot mix the two sources in any way. For me personally, this is a big bummer, though not enough to make me cancel my Apple Music subscription. It just means I will still be buying music for my own collection, which is something they keep promising we won't have to do anymore.

Submitted by MsHollyWeezy on Wednesday, August 5, 2015

Thanks for the help. Im not home but ill try it once i am and get to my computer.