Looking for assistance with erratic voiceover behaviour in safari on amazon's UK site

Forum
macOS and Mac Apps

Hi,

Pulling my hair out here... [Amazon}(http://Amazon.co.uk) seems to have a lot of java on it which is sending voiceover crazy. An example of a page that is hard to navigate is this one which is a random kindle book. Getting down to the heading of the actual title and then navigating through a popover suddenly appears and seems to lock voiceover in.

It's also saying "Loading" a lot.

I did have this sorted before but had to do a fresh install due to sound issues and now I can't remember for the life of me what I did. It's like the voiceover focus is being ambushed. Is there some setting I should have turned off?

Any help would be greatly received.

O

Options

Comments

Submitted by Rob on Thursday, August 23, 2018

Hi, not near my phone so I can't try the link you provided in your post. you may want to try turning on the accessibility object model feature found in your safari settings under experimental features. if you are running a current version of IOS that is...can't remember when that feature was added. also you may want to see if you have pop up blockers enabled. just a thought.

Submitted by Rob on Thursday, August 23, 2018

sorry, just noticed that this was a mac post and not a Iphone post. sorry, ignore my previous reply.

Submitted by Maldalain on Friday, August 24, 2018

Have been through this many times. The only thing that fixes the issue is to disable Java. Enable the developer menu in Safari preferences then disable Java scripts. This does not allow you to proceed with your check-in on Amazon, so proceed with the normal procedure of purchasing your book then copy the link, re-enable Java and paste your link.

Submitted by Oliver Kennett on Friday, August 24, 2018

It's a relief to know someone else is having the issue. I did manage to resolve it some how but did a fresh install and lost those magic settings. Will continue playing and see if I can find a way to get it sorted. Will post here.

Submitted by LaBoheme on Friday, August 24, 2018

i know you are completely loyal to safari, but you might want to know whenever i get into a jam with safari, i just try google chrome, it works just about every time. tried the specific link you posted with chrome, it worked fine.

Submitted by Oliver Kennett on Friday, August 24, 2018

Yes, this is true. It's just vexing having to jump back and forth. Chrome is still not very good at reading out edit box entries and I don't like the way the screen is so crowded with tool bar stuff... But you're right. I'm just trying to find an easier and less fiddly solution.

Submitted by LaBoheme on Saturday, October 27, 2018

let me guess, you don't have kindle unlimited? then your problem is caused by a popup offering the subscription. there are two solutions, i'll give you both and make some observation.

1) the safari solution. safari is loading the page just fine, vo is the problem. what you have to do is command-tab to switch to another application, such as finder, then turn vo off. command-tab to switch back to safari, wait for a few second to make sure everything is kosher, then turn vo back on. you should see the popup and proceed accordingly.

2) the non safari solution. any time you have a problem with safari, just use chrome, it resolves problems nearly 100% of the time.

the funny thing is apple can't make its own software, safari and vo, play nice with each other. apple is a great consumer marketing company, not a great tech company. apple designs its own hardware and software supposedly to make everything work together perfectly, well, see how many issues we've had over the years. if apple has to support other thousands of OEM's like microsoft or google, i doubt it can last for a couple of months.

What is the Accessibility Object Model? I turned it on, but the rest of the features on that screen I left turned off.

ETA: I tried turning off Javascript for that Amazon link and it worked. I'm not from the UK. I was just curious about the problem.