Trouble interacting with Menu Extras in VO

I seem to be encountering problems with accessing menu extras using VO. We currently use VO + space bar when navigating menu extras, which accesses certain extras, such as WiFi and Blutooth, but it doesn't work when used to access Menu tab for Facebook app or Dropbox. When I press VO and spacebar to access one of these apps from the Menu Extras it appears briefly, but then disappears. Can't seem to access them.

Does anyone else have this problem?

Is it a glitch with Voice Over in Mavericks?

Forum: 

Me too

Member of the AppleVis Editorial Team

Hi. I hadn't noticed it until I read your post, but yes I am having the same problem with Dropbox in the menu extras. Very annoying. I'm also on Mavericks.

Accessing the Extra Menus

They seem to be tricky to access. If you have a touchpad available such as if you are using a laptop, I have found this to work the best. Double tap with two fingers at the top center of the touchpad to activate the menu, then touch along the top to find the menus. I find that going right to left makes them show up more often. Then when you find what you are looking for, slide your finger down the touchpad without lifting. It isn't foolproof but seems to work enough to be repeatable though you may have to do the steps a couple of times to get to the choice you want before they seemingly disappear.

Mouse keys is the key

Hi! I remember I struggled with this back in MountainLion also, so this has nothing to do with Mavericks, but with dropbox, this happened after they updated their app sometime earlier this year I believe. There's also been a few other apps that stays in the menubar, where this has started happening the last couple of months, after the app has been updated, so I don't think we can blame Apple for this one. At least not them alone.
I had to find a way of getting around it, and I never tried the track-pad thing, which I will truly do! Sounds like it may be a faster solution than the one I'm about to give you, if it works that is... :)
Ok, here's what I figured.
And let's just use dropbox as the working example.
It may sometimes work to open it with a simulated mouse click, with VO+Shift+Spacebar, but that's a very inconsistent solution. So I did some poking around, and found out that the mouse keys function is the easiest and most reliable way to go.
So you will first have to go to System preferences > Accessibility > Mouse and trackpad > and there you'll find an option to turn mouse keys on. Don't do that. Instead, VO right once until you land on Options for mouse keys. Go in there and check the box for pressing the option key 5 times to toggle mouse keys on or off.
Now you can, as you've probably gathered already, hit the option keys 5 times in quick succession and you will hear a VO sound effect, and VO will also say something like mouse keys on. And of course you can do the same to turn them off , so you can use your keyboard normally again.
So what is mouse keys? On a full sized keyboard it means that you can use the num-pad to control the mouse instead of an external mouse.
I think it's like this:
5 - click the mouse
2 - go down
8 - go up
4- go left
6 - go right
0 - Hold mouse key down
And all the corner keys, like 1, 7, 9 and 3, moves the cursor in a diagonal direction.
But on a normal sized keyboard, that don't have the number pad, it's a bit different. The only thing that is the same, is number key 8, which moves the cursor up. So now it's centered around the letter I, which corresponds to num-pad 5, which I mentioned earlier is used for clicking the mouse.
Ok, enough mumbling, get to the point, you norwegian blind and evil-smelling bastard, you're probably all saying now! Alright alright, no need to get rude, here it is:
Make sure that mouse keys are turned off first. Then go to the menu extras as usual, by hitting VO+M+M, and find your way to the dropbox icon.
Then, make sure that your mouse cursor also has found it's way to the same spot, by hitting VO+F5 to hear what's under the mouse cursor. If mouse cursor is set to follow VO focus in VO utility, this should be unnecessary, but if it's not, hit VO+Cmd+F5 to move the mouse cursor to also be on the dropbox icon, where your VO focus is located.
Now the magic; Tap the option key 5 times to turn mouse keys on, and then press the letter I to click the icon.
if you have a keyboard with a numpad, then you would press number key 5 instead.
Now, the dropbox menu is open, and you can turn mouse keys off again by tapping the option key 5 times rapidly, so you return to normal keyboard.
Then, just go ahead and arrow around in the dropbox menu and have some good dropbox fun as you go along! :)
That's my solution. Maybe it sounds just a little complicated, but I assure you, once you've checked the option in system preferences to let mouse keys be toggled on or off with pressing the option key 5 times, you will never have to think about it again.
And it's a very handy function to have turned on also for other purposes, when simulated mouse clicks through the VO keyboard command just doesn't get the job done.
And the only key you would actually have to remember is the letter I to click the button, and then option to turn the thing off again.
Hope this helps somewhat, and I'll go ahead and check out the treckpad-commander way of doing it! Thanks for that one! :)
Have a good one, everybody! :)

Great

Hello,

You have just provided some great info for some folks that, like me ... were woundering how to simulate a click using a system resource and not a voiceover resource.
This replays the question about how to use something like JAWS cursor and I will try to use it extensively to make things that voiceover lags in mac os which by the way are way too many to work. This is yet another weapon in the arcenal to fight against inaccessible stuff or screen reader wierdness.
And yes yes these wierdnesses do exist on windows and no I am not saying that windows is better ... I am just getting another resource to try to solve problems in the mac.