SMS Messaging on Yosemite

I've done everything to set up my iPhone 6 Plus and my 2014 Mac Mini, both running the latest version of their respective operating systems, to enable handoff and SMS messaging as described and detailed in the article at http://www.igeeksblog.com/setup-handoff-on-mac-os-x-yosemite-and-iphone-... - I do know that I have to have the phone on, which it is, in order to send SMS messages. I have two unsolvable problems:

1. Although Bluetooth is on for both devices, the phone doesn't see the Mac.

2. Although both devices show they are logged in to iCloud, and the Mac is connected to my local Wi-Fi network, I do not see an iCloud account in Messages, Preferences, Accounts tab. Only my regular Messages account, and a Bon Jour account, which is disabled, appear in the accounts list, and it is not possible to add the iCloud account. I can add an account, but it has to be either a Yahoo, AIM, Google Talk, or other unspecified account type.

Oh yes, since my Applecare free phone support expired last July, calling them is not an option, so here I am.

What have I not done, or what can I check on what device to get SMS text messaging enabled on the Mac Mini?

Forum: 

#1 Two Questions

Member of the AppleVis Editorial Team

I want to check two things. First, you said your regular messages account shows up in Messages on the Mac, but what do you mean by that? If that was set up when you logged into iCloud and enabled Messages during setup, that is your iCloud account already.

Second, have you restarted? You will also need to have the phone on the same wifi network as the Mac (no clue why, since they're connected via bluetooth already, but there it is).

#2 I guess I wasn't clear enough

I guess I wasn't clear enough in my first message. If you read the article to which I linked in my original message, there is a detailed list of things one has to do in order to make this work. I've done them all, including restarting. According to the article, I'm supposed to find an account called iCloud. I do not find that account. Only the one called "Messages".

#3 my head is spinning

i believe you are a bit confused. first of all, you are not pairing you iphone with your mac, there is no need for them to "see" each other. and for your particular purpose, it doesn't even use bluetooth, wifi is sufficient, that's why older mac can use this function.
furthermore, you won't find icloud in messages > preferences > account setup. you sign into iMessage with your apple id. iMessage and facetime are not part of icloud, although many people thing they are simply because they sing on to the service using the same apple id. the truth is you can use iMessage and facetime without enabling any icloud services.
the only requirement for what you want to do is to have both devices sing into the same main icloud account. i say "main icloud account" because you can have multiple icloud accounts on one device. the main icloud account is the one with which you can enable find my iphone.

#4 correction

let me just take back something i said. find my iphone can be enable in any icloud account you choose, it doesn't need to be on the main account.

#5 Like I said from the start, I

Like I said from the start, I followed the directions at the cited URL, and those directions said Bluetooth had to be on, so I turned it on. OK, so now I've turned it off, and still nothing doing on the SMS messaging front. The only thing I can't prove is whether my Mac is on the Wi-Fi network with my phone. The network in question is provided by an Apple Airport Express. The phone's on it because it says it is, but I have no sure-fire verifiable way of knowing whether the Mac is. Maybe that is where the problem is. I'll keep at it, though.

#6 Did you forward the number as

Did you forward the number as well? I know you said you did everything, but it's always best to be sure and triple check everything. Also try a permissions repair on osx.

#7 Forward the number? What

Forward the number? What number? How'd I miss this?

#8 forward a number

I believe she means text message forwarding.

#9 And where would I find that?

And where would I find that? ON the phone or the Mac? I've looked everywhere. Every option in Messaging on the phone is turned on.

#10 text message forwarding

You would find that in settings messages and then text message forwarding.

#11 Be aware you need to be by

Be aware you need to be by your mac to enter the code shown on to the phone. It's painless and takes all of about 10 seconds to do. Once you get this working, it should work flawlessly.

Hope that helps.

#12 let me guess

"Like I said from the start, I followed the directions at the cited URL, and those directions said Bluetooth had to be on, so I turned it on. OK, so now I've turned it off, and still nothing doing on the SMS messaging front. The only thing I can't prove is whether my Mac is on the Wi-Fi network with my phone. The network in question is provided by an Apple Airport Express. The phone's on it because it says it is, but I have no sure-fire verifiable way of knowing whether the Mac is. Maybe that is where the problem is. I'll keep at it, though."

you don't have to turn off bluetooth, there may be other functions that need it. it sounds like you have not enable iMessage on your mac. i know you want to send sms, but you do need to enable imessage first so the messages app becomes functional. sign in with your apple id. after you do this, go to settings > messages on your phone, you'll see your mac listed there. you then have to allow it to send sms. and of course these devices have to be on the same iCloud account.

#13 There is nothing in Settings

There is nothing in Settings | Messages that says forwarding, but every option on that screen is on, on, and on, including the one that says "Send as SMS".

#14 Code? What code? The phone

Code? What code? The phone never asked for a code. It simply says "Steve's Mac Mini, connected."

#15 OK, we're getting to the

OK, we're getting to the bottom of this because I went on my phone and discovered that I am not using iCloud for sending iMessages. I fixed that, and bingo, on my Mac came a message that I'd just signed into my iCloud account with my phone, something I thought I'd already done. I guess I did do that before, but it wasn't for the Messages app, it was probably for "Find My iPhone" only. OK, now I'm signed into iCloud with the phone and the Mini. If I look at the Accounts tab in the Mac's Messages | Preferences dialog, it shows I'm logged in, but it only says it's logged on for messages, nothing about iCloud. There's something here that either I'm not doing right, not explaining right, or just isn't possible, but I've been told by everybody that it definitely *is* possible to send SMS messages, those messages going to non-Apple phone and tablet users, from the Macintosh Messages aplication. I know a lot more people without iPhones than with them, and I'd much prefer to use the Mac to do messaging than the phone. The phone and the Mac Mini are both turned on, connected, logged in, properly configured (or so it would seem) ... so I'm truly at a loss as to what to do next.

#16 SMS Text Relay

Steve, you might want to listen to David Woodbridge's AppleVis podcast on SMS Text Relay. It worked for me.

#17 Well wonder of wonders, the

Well wonder of wonders, the one thing I had somehow not noticed, or found, or heard correctly, was the bit about enabling the Mac to relay through the phone. I followed the on-screen instructions without even listening to the rest of David's demonstration, and everything works now! I really don't know how I missed that little detail.

#18 podcast

I also did a podcast on ios 8 way back in October I think. I talk about sms relaying and a bit more. I covered everything in a live interact stream and I think I had a bit too much fun. Here is the post. Feel free to comment on there as well.

Take care and be blessed.