VoiceOver Language detection and wrong punctuation language

Forum
iOS & iPadOS

Hi everyone,

I have some weird problems with VoiceOver, and I'm wondering if there might be any kind soul out there who knows how to fix things.

The first problem I will mention has been bugging me for ages. It happens quite frequently that I'm either receiving emails written in different languages, or visit websites in other languages than my "main phone language". My phone language is set to English, and I'm using Samantha as my main VoiceOver-voice and have two additional voices on the router, Dutch Xander and Swedish Klara. One would expect VoiceOver to just read the text on the site or in the email with the selected voice, but it doesn't. Apparently it automatically detects which language has been used and thus it switches voice to that language, or the language it thinks it's detecting.

Here comes the problem: It happens more often than not that VoiceOver detects the wrong language, and thus tries to read English emails with the Swedish or Dutch voice, and Dutch emails with the Swedish voice, and Swedish emails with the Dutch or English voice. Usually it doesn't care whether I'm trying to switch voice language on the router or not. Turning VoiceOver off and then on again works once in so many tries, but not enough to be even remotly satisfying.

I have gone through the VoiceOver settings one million times to try to solve the problem, but I just can't find any way to turn the language detection off. I would be pleased if it just read things in the selected voice language and did not try to figure out how to read it all by itself, for apparently that's not working. I'm using Jaws on my laptop and I know they have the option to switch language, and even dialect, detection off, but I can't seem to find a similar setting on the phone.

I have been googling this a lot last months, but thus far I haven't found any solution to this problem. I don't know if it's something I'm missing in the VoiceOver settings or if it's a bug or what's going on, so I'm now asking for your help. Does anybody have any idea how to solve this problem? Has anyone else had the same problem?

The second problem is sort of related, but not entirely...
Last week, I finally updated my iphone SE from iOS10.3.3 to iOS11.2.6. VoiceOver has now started to detect the "wrong punctuation language" when I'm typing. This means that if I'm typing with the Swedish voice, she will pronounce all puncuations in Dutch (or at least she tries), and the Dutch voice does the same but in Swedish. Just to be clear: The voices does not switch, but it's like the symbols are "labelled wrongly", so the Swedish one gets the Dutch and the Dutch the Swedish. What the English voice does is a bit random, but usually she goes for the English puctuation words. (And they have also been changed, I've noticed...a period is now called full stop and an apostrophy is now a "single right quotation mark", for instance. I wonder what was wrong with the first ones.)

I have tried to switch the keyboard layout to another language while typing, and have removed the router voices and then added them again, but none of this has helped. It's not a major problem, but it bugs me and since I didn't have this problem before the update to iOS11, I just want to know what's going on and if it's possible to fix it.

Ideas anyone?

It'd be good to know if any of these problems, or both, is something I should report to Apple as a bug. If not, I'm super grateful for any help and advice you might have.

Thanks in advance!

Shass

Options

Comments

Submitted by Frankd on Wednesday, March 21, 2018

Hello,
I recently had a conversation with Apple Accessibility regarding voiceover automatic language selection. My issue was somewhat different from yours although yours sounds more serious.
My issue is with the Overdrive app when reading ebooks that have mathematical expressions containing Greek symbols. I'm unilingual english and learnt the Greek alphabet during my college years but only when pronounced in English. With automatic language selection voiceover is constantly switching between English and Greek when reading a technical publication which is more than distracting. By contrast , the Voice Dream Reader app does a good job of handling this situation insofar that it actually speaks the phrase "Greek letter x" whenever it encounters a Greek symbol.
I made a suggestion to Apple that a feature could be added to the voiceover settings that allowed a user to override automatic language selection which should prevent this problem from occurring. Apple said they would pass along this suggestion to the appropiate group for consideration for incorporation into a future release of iOS. Of course, this wouldn't help your situation. Have you considered contacting Apple Accessibility about your particular problem?
Good luck!

Hi frankd,

Thanks for your reply! Your problem sounds annoying, too. It's actually quite astonishing that Apple hasn't taken any of these things into concideration before. We're on iOS11, and still we can't completely adjust the screenreader to our different needs.

I have concidered reporting these things to Apple, but I first wanted to check with people here on Applevis in case I had just missed out on some crucial setting or something. You never know! I know my way around the phone, but I wouldn't call myself a super-advanced user - far from. And I know there are a lot of people here whose knowledge about the Apple products and VoiceOver in particular are much greater than my own. Thanks for the encouragement however - I guess I'll have to send them a message about it.