Urgent: Incredibly bizarre issue with Voiceover and the Lyft app

iOS & iPadOS

Before anyone asks me, yes. I did open a support ticket regarding this, and I'd strongly encourage all of you to do the same.

Right around this last Christmas of 2018, I noticed something wickedly peculiar going on with Voiceover and the Lyft app on iOS. I should add I'm on the latest build of iOS 12.1.2. Also, my Lyft app is completely up to date. I definitely did look to make sure.

My brother, using iOS 12.1.2 is not, with his iPhone 7 Plus having this issue, but on both my 10, and my 10S, or as some call it, XS, this has totally been reproduced, and about 5 of my other friends are also noticing this.

So, when you open up the app, You hear where to? Double tap to set destination, and get a ride. OK, fine. Glory! So, I double tap this. Now, I'm in the text field to search for a destination, or double tap above the keyboard on one of the locations I've recently been to. So, in my case, I'm just going to pick a place I've been to already in the past. That doesn't matter though. I've tried typing a new location in. Both ways in the long run will produce the same behavior.

Now, I'm on the ride options screen. This is where things epicly are breaking!

I land on something that says swype left to edit ride, or go back. Swype right to select ride mode and adjust payment method. Well, obviously, this doesn't work if I swype left or right with one finger as Voiceover sees that then as a flick. If I 3 finger flick left or right as you'd normally do for things like that when Voiceover is turned on, nothing at all happens. If I 3 finger single tap here, I'm told this item is positioned at the top of the screen. If I then touch explore, I can find the item which is a long white bar that extends horizontally across the top of the screen all the way from the left margin to the right margin. I know this as I have just barely enough vision to see this. the rest of this screen, if you have any color preception just to be sure you're on the same screen I am on sure have a purpleish meginta colored background provided you don't have invert colors turned on. If you do, it'll be bright lime green instead.

Now, if you flick right one time, You hear back button. Now, this is super strange. If you double tap this, nothing at all happens. Further, there is no left arrow looking icon, nor an icon which textually says the word back or anything. I know, as I had a sighted person look. Further, if you try your Voiceover gesture with the two finger scrub right then back left, that doesn't take you back either. Basically, you're now stuck on this screen no matter what, unless you close the app from the app switcher, then go back in, and practically start completely over.

If you flick again right past this back button, which is apparently a ghost button that really has no visual existance, I see in my case, ETA 5 minutes. Obviously, that'll be different for everyone, so don't pannick if your's doesn't say 5 mins. The point is, it'll say ETA, something minutes. Then it says Pickup button pick up at your current GPS location. But then, if you have Voiceover hints enabled like I do, you'll hear double tap to edit pickup location. However, this used to work. You'd double tap, and you'd get a screen identical to the one you got setting your destination, only this time, it would be for where you're being picked up. Now however, this button is totally broken epicly. If you double tap, you're going to hear the little high pitched bwoop as if the page was changing/reloading, same sound when a page finnishes loading in Safari, if that helps... So, you think! it's therefore done something, however, go flick now through your screen. Notice: no keyboard. NO way to search, no list of prior destinations, nothing! You're still on the same blasted screen.

So, there is absolutely no way at all to set your pickup. So, if your GPS location is wrong, then, you're screwed! I have gone in and disabled/re-enabled location services globally throughout iOS, and also have disallowed and re-allowed location services access individually for the Lyft app. I've uninstalled and reinstalled the app, neither of two which methods fixed the problem. I've rebooted my phone, which did no good. I disabled and re-enabled wifi, no good. I disabled and re-enabled cellular LTE, no good. I enabled and disabled airplane mode, no good. I obviously disabled and re-enabled Voiceover, no good. I've closed and reopened the app and tried again, no good. Finally on this screen we're at now, whatever you do, don't dare double tap it, or you'll schedule an actual ride, but flick as far right as you can go. You'll hear an unlabeled button that literally just says button. I know from experience that is the request lyft button, but it's no longer labeled correctly.

So, within say the last half a week or so over this new year, has anyone used the Lyft app, and if so, how did you deal with these issues? Is there a little trick to getting that pick up destination screen to pop up that maybe I'm missing? I did try on that thing telling me to swipe left or right to double tap, hold, then after the 3 little tones swyping left or right with my finger, but that didn't work. I even had a sighted person try swyping left or right on that bar where we thought it wanted us to swype. Obviously, we did this with Voiceover not enabled, but even that didn't work, so either that is an inaccurate Voiceover hint, or, we're not swyping on the correct thing. Again as stated before, just again, I don't wanna have to tell anyone, had you read my post up here you would have red that... finnish the sentence... I will say again, let me be super super super super super super clear, so read this again carefully, and before you respond to this thread, think long and hard. I've already tried 3 finger flicking left or right on that thing telling me to swype, so telling me to do so will be a pointless suggestion. I'm extremely advanced with Voiceover. That isn't to say I know everything. I probably don't, but I've been avidly using it heavily since 2009, so just now going on a decade. And, I train people on using Voiceover professionally as part of my living, so I'd better know my stuff. LOL! Smile. I assure you therefore, I've tried literally everything under the sun! Unless there is a really cockeyed way of dealing with this, I'm totally out of any further options. That's why I'm posting here... I'm literally at my rope's end.



Submitted by gregg on Thursday, January 3, 2019

It appears from your description, and my test on 6 plus, the problem is with the newer iPhones.So telling Apple the model of iPhone will be important.

Submitted by Kareem Dale on Friday, January 4, 2019

Club AppleVis Member

Thanks very much for sharing this experience. This is precisely why I rarely update my Apps until a long time after the update for any App comes out so I can see if there are any accessibility issues as these developers often break things. Very sorry you are having this issue but definitely important to share with the community so thanks again. I am not having any issues but, as I stated, my App is not updated probably since 3 or 4 or maybe more of the last Lyft updates.

Submitted by Chris Gilland on Friday, January 4, 2019


I talked more to Apple Accessibility, and I think we've found out what is going on. The key however is going to be trying to figure out a good way to explain this concept to the Lyft development team.

Basically, I'm not sure if this even is fully a Voiceover problem at this point, though it may partially be. The jist of it is, on the second screen where I started having the problems I experienced, for newer, it seems, iOS devices like the iPhone X, XS, XS Max, and XR, have newer API's, and different hooks which must be utilized by developers within their Swift coding when coding apps for compatibility with these newer devices.

What has apparently happened here with the Lyft app in this most recent update is that they didn't include those correct API's, therefore relying on the old ones instead. Obviously, this won't break accessibility on devices like the 6, 6 Plus, 6S, 7, 7 Plus, etc. I believe this problem only starts with the X series. Meaning, the 10 or newer.

What's occuring is, those buttons like editting your pickup location, that back button, etc, that do nothing when double tapped are being hidden/covered by the rest of the screen. Even with Voiceover not enabled this is the case.

In fact, to be completely transparent here with you all, with no Voiceover in the equasion, you'd visually have no way, from what Apple told me whilst doing a screen share, of knowing that those icons even existed. The only way that they visually knew was because they heard Voiceover speaking those icons, and their associated labels, but visually on the screen, the box indicating the Voiceover cursor is actually around just an empty part of the screen within the area that contains the purple background, which actually is a majority of that second screen.

So, the best way I could explain this to you all is, think like a layered cake. It's kind of that same type concept. For the more dev savvy/techies, it's like an OLE, or as some would call it, a floating window.

In other words, more simply put in elementary terms, those buttons are being covered up because the majority 95 percent of the screen is layered over the top of the buttons. This is why when Voiceover is focused on those icons, visually, the box indicating the focus cursor point position is actually bordering around just blank screen real estate. So, what needs to happen is, those buttons cannot be activated by a sighted, nor a blind Voiceover user, as they're layered behind the main app's UI screen interface. Those buttons need to be placed in the main window instead of off in the background. Basically, Lyft needs to do the same thing they did with the buttons to select the type car you want, or the request Lyft button in the bottom right corner. Those buttons are not layered behind the other content. They are correctly positioned in XCode on the storyboard for that screen in the app.

My suspition is though the other buttons were perportionally placed at the correct position on the storyboard, within the swift coding for those buttons, they forgot to implement the newer and correct API kits to make those buttons tappable... or in our case, double tappable.

This is a really really easy fix, but, it's gonna be trying to find a way to explain this concept to Lyft where they'll understand. This is why I encourage not just myself but all you Lyft users to write Lyft and try voicing what is going on in such a way that they can understand. Keep it to the point, don't ramble on, but at least make sure they understand what's happening. Anyone up here who sees this and is a dev, it's people like you all who can really help most, as you all understand how the API's work, and how things need to be done, therefore, you all possess the knowledge to better inform Lyft of the exacts in the problem at hand. That said, if you're not a dev, don't be discouraged from writing them. I'm simply saying that if you *are*, it may speak more volumes, but that absolutely doesn't exempt others from contacting them as well.

I appreciate everyone's cooperation in this, and hopefully we can educate them on what to do to fix this problem. Trust me when I say, really truely, it is! a very easy fix.

Submitted by Jo on Friday, January 4, 2019

I tried to schedule a Lyft ride in advance this morning for later this evening. However, the picker that lets me select the time would only show 10 or 11 o'clock A.M. So I had to get my husband to help me select the time for the ride. The day picker worked fine. I've never had this issue before and I'm running the latest 12.1.2 iOS update on an iPhone 8. Can someone tell me how to write up a support ticket? Thanks.

Submitted by Melissa Roe on Friday, January 4, 2019

Has anyone noticed a recent issue that has also come to pass with lift? I have multiple credit cards that I use, and when I want to switch to a particular one, even though I select the card, lift it does not do it. I can tap on the card I want to use until I’m blue in the face, but I am stuck with one payment method, and therefore have been unable to use Lyft for a little over a month now. Now that things are quieting down for the holidays, I also want to submit this issue to their support team, but I wanted to ask anyone else if they also have been experiencing this issue. My roommate has experienced this issue as well, and she uses Zumba instead of voiceover. Your comments will be well appreciated. Thank you and take care.

Submitted by Chris Gilland on Saturday, January 5, 2019

Maybe I don't get the concept correctly, but what does it mean be it Applevis, or not, on a forum like this to hijack someone elses thread?

Enough said.

Submitted by Chris Gilland on Saturday, January 5, 2019


I cannot yet post the exact response, as I've not quite yet heard back if I have permission or not to do so, so I have to be somewhat general about this, forgive me, but this much, I *am* at liberty to tell you all... I did indeed hear back from Lyft, and they have confirmed that not only were they able to reproduce these issues I initially described, but they basically said my description of what was going on was absolutely fantastic. They said it was obvious that I know what I'm talking about. Anyway, the next app update which, they did give a date for, but again, I'm not sure if I'm supposed to yet reveal it, will have these issues fixed. What I can tell you at this point is, it will be in the next 2 weeks, if not sooner. I also can tell you that they sent me a beta of the new update, and I can confirm beyond a doubt that most of the issues are fixed. There are still one or two things, but those things will be taken care of by the time you all get the official release.

So, my point is, everyone just hang tight. They are aware of things, and are almost ready to release the fix. Also, they told me that one of you all also submitted to them this exact forum posting. I want to say though I have no idea who did that specifically, and BTW, feel free to remain anonynous, thank you profusely! for doing that! And to everyone else who also wrote Lyft as I did, you guys are freaking awesome! Thank you thank you thank you!

Everyone have an amazing evening.


Submitted by Chris Gilland on Tuesday, January 8, 2019


Jacob from Lyft Customer Care has given me permission to share publicly with you all his exact e-mail he sent me the other day which states these problems will be fixed. So, with no further adue, here it is:

Hey there Christopher,

Thanks for reaching out to us here at Lyft Support! I will be stepping in for Franz. 

I have recently received an email from someone else having the same issues. They even referenced the forum post you wrote since it summed up the issues
so well. I got in touch with some of our Software Engineers who work with iOS builds, and they have confirmed that they are aware of the issues you are

They let me know that the majority of the issues will be resolved with the next app release, which will occur around January 16. I apologize that we have
to wait for that next app release for these to be resolved, but we appreciate your feedback and your patience as the team works to make the app as accessible
as possible. Thanks for being a loyal Lyft user, and if you have any questions in the meantime, don't hesitate to reach back out!

All the best,