Subscribing to password protected podcasts with the IOS apple podcast app

iOS & iPadOS


Using the RNIB talking newspapers service here in the UK. The audio RSS feed requires password authentication which doesn't seem to be an option in the podcast app. Anyone got any advice?

I know there are other players out there but I like the podcast app and how it is laid out. Tried overcast but found it a bit lacking and none of the notifications seem to work.

Also want to stay with the podcasts app as it syncs across all my IOS devices including homepod.





Submitted by Paul on Wednesday, September 4, 2019

You add a password-protected podcast just like any other that you add manually by URL. Assuming they use HTTP authentication, the app will prompt you for the username and password when you attempt to add the password-protected RSS feed.

Submitted by Oliver Kennett on Wednesday, September 4, 2019

It asks me for username and password when I use overcast, in apple Podcasts, nada.

Submitted by Paul on Wednesday, September 4, 2019

I happen to be able to simulate a scenario in which an RSS feed is password protected by HTTP authentication and found that the Podcasts app on iOS 12.4.1 did in fact prompt for a username and password. But, here's a couple of things to consider.

If trying to add the URL doesn't result in an error, and you can see and listen to episodes, you don't need to do anything further.

If you try to access the RSS feed in a normal browser and you're prompted to login using an HTML form, rather than an HTTP authentication dialog, then you won't be able to add the podcast unless logging in with a normal browser results in the URL changing to contain your username and password or the URL changes to one with a unique ID that doesn't change and doesn't require re-authentication. If you get one of the types of URL described, that's likely the URL you'll need to use, assuming it is actually an RSS feed you're taken to when you login.

If the Podcasts app tells you the server or feed can't be found, make sure you're entering a URL that points to an RSS feed containing audio files. Being required to login using an HTML form would also likely cause this error.

Beyond that, I can't help you further without more information like the URL you're trying to use, the steps you take to add the podcast, and what happens when you try to add it. You might also consider contacting the RNIB to find out if and how you can add their feed to the builtin Podcasts app.

Submitted by Oliver Kennett on Wednesday, September 4, 2019

Yeah, I've tried the RNIB but they suggest another app. As I say, it prompts for password if I use Overcast, another podcast app.

An example of the RSS I'm looking at is:…

Which I add in the podcast app as a URL. It does seem to add okay but when I come to play it does say, this podcast is temporally unavailable.

If you're able to log in to similar feeds, this should work. It just seems so close but no cigar, as they say.

Submitted by Paul on Wednesday, September 4, 2019

I tried that link and it worked as I expected it to. It uses HTTP authentication and the Podcasts app should be prompting you for your credentials (which might take a second or two) when you add the URL. It says something along the lines of "To continue receiving updates you need to sign in." If that isn't happening, it could be that you're using a device or iOS version that doesn't support HTTP authentication for podcasts in the Apple Podcasts app. However, since HTTP authentication is a basic piece of functionality, I highly doubt this is the case.

I would delete the podcast from your library completely, if you haven't done so already, restart your device, and try adding it again, making sure you include the URL scheme (i.e. "http://") and everything after the "?".

If it still doesn't work, your best course of action would probably be to contact Apple, or to make a Genius bar appointment if you have a near by Apple store you can get to, because it should be working exactly as I described. For reference, I'm using an iPhone running iOS 12.4.1.

Submitted by Oliver Kennett on Thursday, September 5, 2019

Thanks so much for the time you have taken to reply. It would appear that time was all it needed. I tried subscribing through itunes using the alternative itunes subscription link which was causing the same behaviour. I just opened the podcast app on my iphone running 13.1 (Had the same issue when on 12.4), and it's working!

It's certainly a comfort to know that it should and does work. It might have been issues with itunes on my mac trying to sync though I did try deleting and adding through the IOS app independently. It's certainly not as smooth as I'd have expected but I'm very glad it's all working now. I know the podcast app gets a bad wrap but it is convenient and, to me, remains a good way of accessing and sorting podcasts.

All the best


Submitted by Oliver Kennett on Friday, September 27, 2019

So, unfortunately I can't recreate this where the podcast actually works. I've had to reinstall Mac OS for various reasons and upgraded to IOS 13.1.

I did notice that, when I pulled up one of the feeds, the example I gave in a previous post, voiceover did say something like:

'It looks like we need a password for this"

But when I went searching for this dialogue, it wasn't anywhere to be found.

It's so frustrating, it did work and I'm not quite sure why but it might have been because I subscribed via iTunes.

Any ideas?