Problem with Lire and Feedly

Member of the AppleVis Blog Team
Forum
iOS & iPadOS

For some time I have been unable to sync Lire with Feedly. It works fine in standalone mode, and logging into feedly directly also works. They just seem not to like each other these days. When I try to fetch the latest articles I get an error message which I have put at the end of this post. Is this more likely to be a problem with Lire or with Feedly, and does anyone know how to fix it? The error message is as follows:

Request failed: client error (429)

<NSHTTPURLResponse: 0x1c082a060> { URL: https://cloud.feedly.com/v3/streams/ids?count=10000&streamId=user/d3984… } { status code: 429, headers { "Cache-Control" = "no-cache"; "Content-Type" = "text/plain"; Date = "Sun, 22 Oct 2017 20:16:02 GMT"; Server = "cloudflare-nginx"; "cf-ray" = "3b1f21cddb6334be-LHR"; "retry-after" = 60; } }

Options

Comments

Submitted by Moses Gitari on Monday, November 27, 2017

Hello Lysette Chaproniere,
I’m experiencing the same problem on this end. Did you figure out how to fix this problem?
Thanks.

Submitted by peter on Tuesday, November 28, 2017

I don't know what Lire is (I presume it is a podcatching program), but I noticed from the URL that the site uses SSL certificates.

Some legacy podcatcher programs will not work with sites that use SSL certificates (i.e., URL's that start with https). You might have to try a newer podcatcher or ask the developers to update the code.

Fortunately Apple foresaw this coming a few years ago and iTunes has been made to work with https sites for some time now.

Hope that helps.

--Pete

Submitted by Moses Gitari on Tuesday, November 28, 2017

In reply to by peter

Hi Peter,
Thanks for your input.

Lire is an RSS reader. Fortunately I have managed to fix the problem. Logging out and in to my Feedly account under lire settings has worked like Magic. regards.

Submitted by Lysette Chaproniere on Tuesday, November 28, 2017

Member of the AppleVis Blog Team

I emailed the developer about this problem, and he suggested logging out and back in. The first time I tried that it didn’t work, but I managed to solve the problem by reinstalling the app. I probably should’ve tried that before asking for help. Anyway, it all seems to be working now.

Submitted by splyt on Tuesday, November 28, 2017

Take care with recomendations.

Lire is simply the best ever rss reader for iOS and is being actively maintained ... assuming that there is something wrong and replacing it by another solution without asking the developper for help would be a completely wrong move in my opinion.

Never assume something from a piece of software you do not know. Ask for help first, specially if the app is a must have like Lire is.

Even having solved the problem it would be worth to send a note to the Lire developper to let him know, if he yet does not know, that something wrong is going on. Here nothing happened at all.