long standing bug voiceover talking over audio messages and voicemails

I've noticed since way back when I can't remember what version this started my voiceover will sometimes talk over a text audio message or a voicemail. The 2 finger single tap will not work in this case. Does anyone have a work around for this? It's annoying having to replay a voicemail or a text audio message do to this.

Forum: 

Listening to voice mails has always been a problem when using Vo

Yes, it is a problem that, when listening to voice mail m messages one has to flick around to find the speaker button while listening to VO and the message playing at the ssame time. I haven't found a way of turning on the speaker after activating a voice mail. As soon as I activate a voice mail in the list of mesages, the message starts playing as if I had the phone held up to my ear. It is often so quiet I can barely hear it. Then I try to flick around or stop the message while trying to listen to VO.

What I would like to see is for voice messages to work the same as phone calls do when listening to phone calls, i.e., if I hold the phone away from me the phone should use the speaker and if I hold the phone close to my ear it should not use the speaker.

As you say, this has been very broken for a long, long time.

--Peteg

Been using this handy tip for a while now

VoiceOver, as a Screen Reader, is doing exactly what it is designed to do, read the screen, including giving you feedback when you perform actions. So, with this in mind, before playing a VoiceMail, What'sApp message, audio iMessage, etc. Just find the control that starts the audio and right before doing a one-finger double-tap, do a three-finger double-tap to turn off speech. This only prevents the voice itself from speaking. VoiceOver is still running, so you can still perform gestures as you would when hearing speech. Useful if you know an App's layout very well and want to quickly click a few buttons without a bunch of speech you don't really need. Voicemail messages not respecting the proximity sensor, if that is in fact what is happening, is indeed a bug and is highly annoying, so that's why I just find the voicemail I want, turn off speech, then start the voicemail playing while holding the phone next to my ear so I can put it on my ear as soon as the Voicemail starts.

Good workaround but...

Yes, I agree we can work around this issue. I don't think the proximity sensor is designed to work in voice mail mesages as it does when on an actual call, but it sure would be nice if it did.

The real problem here is that, if one does want to listen on the speaker, then one has to hold the phone away from one's ear while the mesage automatically starts playing silently. While navigating with VoiceOver to find the speaker button and having the phone away from one's ear, the problem is exascerbated since now VoiceOver is at normal volume whie the mesage is playing silently. The worst of both worlds.

I haven't figured out any way of putting the phone in speaker mode before playing a message. If that could be done and/or the phone would use the proximity sensor, that would solve most of the problem.

I'm guessing that sometimes the folks who design these systems and how they work aren't the actual users.

--Pete

Indeed

Yes, the fact you can't put a Voicemail on speaker before starting it is why I suggested that work around mainly. You are correct, you can't hear speech very well when it's going through the earpiece.