AIAdventure is not seeming to work for me.

iOS & iPadOS Gaming
I'm not sure if anyone else is also noticing this, however I am using the most recent version of AIAdventure. I just downloaded/installed it last night. I am finding that 95 percent of the time that I give my spoken commands, the game is not recognising what I am saying. Let me be a bit more specific. When I say it's not recognizing my commands, I don't mean it's not allowing me to make a certain move... for example... go west... well, I can't move that direction, so it doesn't allow me to do so. that isn't what I'm saying. I'm saying it's not even acknowledging in the first place that I'm giving it commands. I'm speaking very clearly, and if you all've heard any of the podcasts I've submitted up here, then you know, I have a very clear speaking voice. I don't have any sort of an impediment. It's not even just on one area of the game. For instance, when you first start the game, you're in that building with the keys on the floor, the bottle of water, and tasty food. I've managed to say take bottle, which worked inconsistently. I've said drink bottle which didn't really work although part of that might be I first have to take it before I can drink it, but even if that be the case, he should have at least told me that I couldn't make that move. I've tried saying take food, which I think by about the second or 3rd attempt worked. I've tried asking for my invintory, which only worked once, although after that, I got really stuck and 99 percent of my commands quit working past that point. I've tried giving cardinal directions, like go east, go west, go north, go south, turn left, turn right, go straight, turn around, sing ta ra ra boom dee ey, ok, just kidding. no, I didn't really do that last one, I'm kidding. Seriously though... none of those worked very consistently. I'm finding that I hear background ambiance noise, like maybe dripping water or something, and sometimes when I give commands it gets real choppy, stopping for about half a second, then resuming. Nothing aside from that happens though. It almost reminds me of one of the most terrible audio edits you ever could do. Let's just say that if I hiered you to edit for me, and you made an edit like that, you'd be fired on the spot! It's incredibly obvious. So, I'm not totally sure what it's doing there. It's almost like it's trying to take the command, but is getting hung while doing so. I've said help, and that worked maybe twice out of say the 4 or 5 times I've tried it. I've tried shutting off Voiceover which had absolutely no baring whatsoever. I've tried rotating the phone just in case maybe that mattered, although that had no effect. I should add I tried rotating with orientation locked both on portrait and on landscape modes. I also tried with it unlocked on both modes. Again, no luck any of those combinations. I've popped my otterbox defender case off my phone, just in case something was obstructing the built in microphone, but it had no effect. I tried using the IPhone 5 earbuds while playing which had no effect. I tried an older pare of earbuds from an IPod Touch 4th Generation that I used to have, which had no effect. I tried a pare of old Android earbuds that I got back in the days with my old T-Mobile Motorola charm, which had no good effect. I tried with my RF M A B2 Rocketfish stereo bluetooth headset, I've tried with my MM100 Stereo Senheisser bluetooth headset with no good luck, I've tried with a standard pare of IFrog earphones, with no luck. Finally, I even tried with my Aftershokz Sports bone induction headphones, (which I swear by, by the way...) with no luck. I've powered the phone off, and back on with no effect. I've quintupple pressed quickly my sleep button to reset the springboard, I've tried altering my wording a bit on my verbs, so like, instead of saying go west, I tried saying walk west, turn west, move west, I've even tried leaving the verb entirely out altogether and just letting it be infered, such as simply saying: west, south, left, right, up, down, etc. no good. I've change my diction/inflection a bit as well. Like I've tried: Take bottle, Take? bottle, take bottle? Take? bottle? take! Bottle! takeboddle. I've tried bott'tt'ttle as well as bodd'dd'ddle. In other wordes b o tt! l e, as well as b o DD! l e. tull, verses dull. No good. I've eaven worked with the l phoneme a bit, and tried tull, dull, toal, dole, dall, tall, ððall, instead of dall, in other words the dental tap verses the hard d, Nothing is working. I'm just wonderring if anyone else is having these problems and if so, how did you fix it? I'm using an AT&T locked IPhone 5, non-jailbroken, black 64 gig, running I O S 6.1.4. Thanks for any, and all help. Chris.