Problem with Launching Agogo

Club AppleVis Member
After reading the recommendation for Agogo, I downloaded it from the App Store. I am using an iPhone 4S running IOS 7.1. When I launch the app, nothing happens for about a minute and it then closes. Has anyone experienced this problem, or is it something I am doing wrong? Thanks for any help.

Forum: 

#1 Looks like the app is

Looks like the app is crashing. have you tried reinstalling the app to see if tha works?

good luck.

#2 Agogo

Club AppleVis Member

Thanks for your suggestion. I deleted and re-installed the app twice, and did a hard reset on my iPhone. Nothing seems to work. I wonder if the app is compatible with the iPhone 4S, or does it require a 5 or 5S. Thanks.

#3 What does it say on the

What does it say on the iTunes description? does it say comparable with your iPhone or not. This would be a good place to start troubleshooting.

#4 Fixing your AGOGO!

App Developer

Hi Wayne, Lead developer of AGOGO here - I'm super bummed this is happening! I have a hunch that the app might be crashing when it is scanning your music library. By chance do you have a lot of music on your iPhone 4s? Thanks in advance for any help.

#5 Problem launching Agogo

Club AppleVis Member

Hi Robert. That may be the problem. I have over 7,400 songs in my library on my iPhone. Thanks for responding so quickly and looking into this.

#6 On its way

App Developer

Thanks Wayne, Other users have reported a similar problem and I am working on fix right now. I'll post here when the new build is in the app store. Thank you so much for you patience. -R