How do I get the Capslock key in windows to work with narrator when in VMWare Fusion

Snappy title huh?

So I've installed windows on my MBA using VMWare Fusion however, when trying to learn how to use the windows inbuilt screenreader, I discovered that though narrater is voicing the caps lock key, it isn't activating the scan mode or the mode to export the keyboard, IE the VO K equivalent which should be Capslock 1.

Is this an issue with keyboard mapping? Am I just being stupid? Are there better alternatives to narrater that bypass this problem? Ar there any scripts etc that get windows screen readers to behave in the same way as VoiceOver with the same keystrokes?

Any answers will be useful.

Thanks

O

Forum: 

#1 Using caps lock key in Fusion

This is somewhat trickier than ideally it would be but it is possible; I use Jaws in a Windows 10 VM under Fusion daily with the caps lock key used as the Jaws key. You need set up a few configurations and use 2 additional pieces of software.

1. On your Mac under System preferences -> Keyboard -> Modifier keys set Caps lock to 'No action'
2. In the voiceOver utility set VO to only use command/option as VO keys and not caps lock
3. On your Mac install Karabiner Elements (link below) and use it to map the caps lock key to some key you don't use, I use numeric keypad 1
4. In the Windows VM install SharpKeys (link below) and map the key chosen above (in my case numeric keypad 1) back to caps lock.

It is fiddly and annoying but once set up it just works.

Karabiner Elements: https://pqrs.org/osx/karabiner/
SharpKeys: https://www.randyrants.com/category/sharpkeys/

#2 Superb

Thank you so much for taking the time to give me such a complete answer. Okay, that's good I'll get that done.

Just whilst I have you, to remain within windows so that keyboard control is working with it, is it command control f? how do I alt tab through windows as this seems to jump me out of VMWare Fusion, or is that not a thing?

I've not used windows for a decade so my understanding of the platform is somewhat vague.

#3 So if I read post 1 correctly

So if I read post 1 correctly, if i want caps lock to work in a VM as a screenreader modifier, I can not use it as my voiceover modifier in MacOS?

#4 remap

App Developer

Another far less fiddly way would be to map the Windows insert or caps-lock keys to a macOS key combo from within Fusion's preferences. That is what I do.
This assumes of course that you are willing to use another key combo other than the caps-lock specifically.

#5 Command-tab and use of caps lock as VO key

Re comment 2 - in Fusion preferences go to Keyboard and Mouse and disable Mac Host Shortcuts. This way things like command-tab get sent to the VM and not the Mac. You use control-command to release focus from the VM.
For comment 3 - if you are using caps lock as your VO keys the problem is that when in the VM the caps lock gets intercepted by VO instead of going to the Windows screen reader. You could of course turn VO off while in the Windows VM. For me I jump back and forth enough that this doesn't get under my annoyance threshold.

And of course the last commentor is absolutely right, if you are open to use another key for your Windows screen reader then it can be somewhat simpler. But my muscle memory of caps lock as my Windows screen reader command key is just too strong!

#6 Wonderful

That's great... Unfortunately even when I turn off the host mapping command tab continues to work as before... Hmm.

#7 Alt Tab

App Developer

You need to use option-tab to switch between running applications. The option key is the same as alt in Windows.

#8 More questions

I've been trying to live without the caps lock key in my Windows VM because NVDA and JAWS are willing to use insert. Of course my Mac keyboard doesn't have an insert key, but I successfully remapped the ` (accent) to insert in Windows with a flaky half accessible key mapper I won't recommend. The problem is that Narrator doesn't seem to allow any key but caps lock to control it, and I really should learn to use Narrator some.
I keep failing in my attempts to make any type of key remapping work for the caps lock. My question is: how does a screen reader user enter the necessary keys in the dialog in VMWare Fusion? If I'm not running VO I can't figure out what I'm doing, but if I am than either the wrong keys end up in the box or nothing ends up there because VO ate the keypress. The bypass Vo command doesn't seem to work either.
Also, does anyone know a command to force Fusion to capture keyboard input? I have far more trouble getting it to capture input than I do getting it to release it.

#9 Key-mapping Dialog

App Developer

The way I do it is to vo-space on the combo box. That will bring up a list of keys. Move vo to the desired key and stop interacting with the combobox. I have to vo-shift-up twice.

Fusion used to have a command to capture the keyboard, but unfortunately they did away with it long time ago. I just hit tab or option-tab until it captures it. It usually does after a few tries.
Hope that helps.

#10 Narrator key options - Caps Lock, Insert, or both

If you are using Windows 10, build 17763 (October 2018 Update) or later, both the Caps lock and Insert keys serve as the Narrator key by default. You can change this in the Narrator Setting (Windows + Control + N) as well using the "Select Narrator Key" combo box, the options are Caps Lock, Insert, or Caps Lock or Insert. For more information: http://aka.ms/narratorguide (Chapter 2 Narrator basics).
Try and see if this works for you. Thanks.

#11 Thanks

Embarrassingly I hadn't realized my Windows version had failed to install updates and was very behind. Once I got it to update fully I got the Narrator option I so badly needed. My fake insert key now works very well as the Narrator key. Thanks for the tip.

#12 Thanks but no success

Your directions in changing key mapping for Fusion were good. I found that combo-box a bit strange to operate with VO so in the past I'm not sure I succeeded in making the change I wanted. Now I see that the key has been remapped according to Fusion preferences, but nothing actually works. It just goes on passing the original un-modified key through. Now everything is even worse because Mac OS Catalina doesn't allow the logitech software for my keyboard to run, so I don't even have all the right function keys without pressing FN. Karabiner Elements doesn't change anything either. I've checked that both Karabiner and VMWare Fusion have input monitoring permission, but changing key bindings just doesn't work for anything now.