Bug in the mail Application

I have an iPhone 5s with IOS 9.3.4 installed. I'm a french Canadian user. I use IOS with the French language. I wil try to explain my bug, but it is possible that the titles that I use are not those in English. I hope that it wil be comprehensible though.

Sometimes ago, I noticed a potential problem in the Mail application. I would like to know if somebody have noticed it ans found a solution, before transmitting it to Apple.

I have a Hotmail account that I use regurarly. I have two other accounts that are less used. When i go in the «All inbox» i have no unread messages. However, if I go in the list of accounts display, I have a notification that I have one (1) unread message in the Hotmail account. If i open the Hotmail account, in the Inbox tab, I have also a notification for an unread message. When I open the Hotmail Inbox tab there are no visible unreadmessage.

I have not this problem with my others account. One is with an ISP an the other is an iCloud account. In these accounts I have the correct number of unread messages. The icon on the home page present also the correct number of unread messages. It's only in the Accounts page of the Mail application that the bug appears.

Is there a solution or should I mention it to Apple.

Thanks!

Forum: 

#1 Try searching for unread messages

This has happened to me before. Try searching for unread in the search field of that account.

#2 Searching unread messages?

Is there a method to search unread messages or should lok them one at a time. In the second case, I do not find any unread message in the Inbox. I do not find unread message in Outlook on my laptop with Windows 7..

#3 Phantom unread messages

Hello there,
I've seen this problem before, though it was with an Exchange server not Hotmail. In any case I believe Hotmail uses the Exchange protocol to communicate these days, so the same bug can apply here. You have no unread messages, just a stuck counter. For what it's worth, it's a bug in iOS and nothing to do with accessibility at all.
The way you fix it is to force your mail to resynchronize. I don't know French (only a few words) so my steps will be in English. Go to Settings, then Mail, Contacts, and Calendars. Double tap your hotmail account. In this screen you should see toggles for Mail, Contacts, Calendars, Notes, etc. Turn Mail off, and when iOS asks if you're sure, confirm the operation. Wait about 15 seconds then turn Mail back on. This will force your account to resynchronize with Hotmail's server and, after a few minutes, the spurious unread message count should go away.

#4 It worked

It has worked fine. Many Thanks.