Audio Hijack help

Hi, Sean here. I just recently purchased Audio Hijack 3 and am really loving it so far. I just need to figure out a few things. I was able to start it up, I had it use the System audio template and was then able to add my Olympus DM20 recorder's mic as an input. But, for some reason, the mic and the system audio are being recorded in to 2 separate files. Could anyone please help me adjust things so everything get's recorded in to 1 audio file. But, I wanna make it so I don't hear the mic coming back at me through the speaker. Thanks so very much for your help in advance.

Forum: 

#1 RE: Audio Hijack help

Hi Sean!

I'm new to Audio Hijack3 as you are, but I believe I have a suggestion: Check to see if you have multiple recordings added as outputs. You only need to have one recording. I would personally have the chain set up as follows:

  1. Microphone
  2. System audio
  3. Recording to my chosen fileformat.

As you may notice I have not selected any soundcard/headphones as an output, because that will make the sound go to your ears through the chosen sound-output. If you haven't done so, try to listen to the podcast Alex Wallis (excuse me if I misspelled your last name, Alex). It really helped me out, when I played with it earlier. Jonathan Mosen has done a recording as well, demonstrating Audio hijack. You'll find it on audioboom.fm/jmosen under his last booms.

#2 Adding connections

Okay, how do I add connections from one thing to another? When I copied system audio and pasted it into the audio block grid, it said that it was posted at one X1Y and the other was posted next to it to the right. No connections were available though. Also, how am I able to hear everything when I'm recording. I need to be able to hear the system audio, but I don't want to hear my microphone coming back at me. Thanks a lot again for your help.

#3 IMPORTANT CORRECTION

Hi again Sean!

So sorry I failed at my first try to help you out. If you did what I suggested in #1 you may have been scared since we just completely muted your systemaudio! This is done by mistake. I will again suggest that you listen to the podcast that either Jonathan and/or Alex Wallis have done, because it is a program that need very much practise before you get it right. I just tried to setup what you want, finding myself to break connections all over the place. I'll give another shot later tonight, and if I get anything to work, I'll get back to you.

#4 Jonathan's podcast.

Is there anyway that you can give a direct audio link so that I can download Jonathan's podcast? Thank you very much. And also, thanks for your help. I really appreciate it!

#5 Got it figured out!!!

Ok, I got it figured out. It is a bit complicated, but quite easy once you understand what you are doing.
So, We are going to record from whatever mic you have, wether it be internal, or external. The way we do this is to create a new setion to start so you have an empty audio grid. Then go to your "Audio Block Library", interact with it with VO Shift down arrow, and find the sources tab. Interact with this in the same way as you did the audio block library. and find your Input Device. It will then use what ever you have as your default input, what you would be recording with You will then need to copy this to the clipboard by pressing VO space. then Stop interacting with bothe the sources tab and the audio block library by pressing VO Shift up arrow. then go back to your Audio Grid and interact with it and press command v to paste the input in the grid. it will be placed at 1x 1y. Now you need to stop interacting with the grid and go back to your audio block library, interact with it, then find the output tab, interact with it and find and copy the Recorder option. Again, stop interacting with both the outputs tab and the audio block library and go back to and interact with the audio grid. There, you will paste the recorder option. Now, heres a bit of a tricky thing, because you just pasted the recorder, it is now at 1x 1y. You will need to move to the right with VO right arrow to find the mic input option and press command left arrow to move it back to 1x 1y. When you do this. the Recorder, or by default, the MP3 option will have moved to 1 x 2 y.. Now that you have that. You will need to stop interacting with the grid again. and go back to the audio block library. interact with it and the sources tab and find an option called system audio. copy it, stop interacting with the sources and audio block library and go back to the audio grid. Interact with it, and paste the system audio. Now, it is now at 1x 1y. You will need to move it down one to 1x 2y by pressing command down arrow. and go back up and move first the mic input back to 1x 1y then move the MP3 back to 2x 1y by pressing command left arrow. Now if you want to hear everything. you will need to stop interacting with the grid, interact with the audio block library, then interact with the outputs tab, and find the option Output device. copy it. stop interacting with everything and go back to the grid. interact with it and paste the output device. It is also now at 1x 1y. you will need to move it to 3x 1y with command right arrow. If you have the output device in your audio chain, you will need headphones so you don't get feedback from your mic or whatever input divec you might be using. Now you can stop interacting with the grid, move over to the record button and give it a try. It worked perfectly for me. This setup allows everything to be recorded to 1 file. Hope this helps anyone that may have had trouble with this.

#6 RE: Got it figured out!!!

Hi Sean! Great, I got the same setup working a few minutes ago. The only thing I couldn't get to work is your original question: How to mute the mic from the speaker-output? Therefor I've contacted the company. If no one else fiugres this out, they'll hopefully give a great answer. :-) Best regards Thomas

#7 Awesome, thanks a lot. I

Awesome, thanks a lot. I really appreciate it. Audio Hijack is quite fun.

#8 Sean, I figured it out!

Hello Sean!

Sorry for all this confusion. I contacted the company, and got a answer that it took me a while to figure out. But now I got it to work on my system. Here's how to set it up. Read this first, and then to my thoughts below:

  1. Systemaudio x1y1
  2. Recording to file x2y1
  3. Your microphone x1y2
  4. Another systemaudio x1y3
  5. Headphones/speakers-output x2y4

As you see above there are two inputs for the systemaudio. One goes to the recording to the audio-file. The other goes directly to your speakers, so the microphone is only shown in the sound-file, not in your speakers while you're recording. The key here is to understand how to set chains up. What confused me was the fact that you have to break the connection in some cases to get what you are asking for here. In fact we do break a connection to the systemaudio when we move the speakers down one row so it is placed at Y4. That means it will not be able to receive audio from any other input than the systemaudio at Y3. We want that, because if it is placed at Y3 next to the systemaudio at x1y3 it still is connected to the microphone.

Actually while playing with this setup I discovered something that might confuse people like myself: When I navigated I used the arrow-keys instead of Voiceover keys. The very nice thing about this (after I got the point of it) is that Audio Hijack groups connections, so you can see how it is connected. For example: Remember that we in this example have Systemaudio1 and microphone as two inputs going to the recording-output. This output is at 2xy1. But when we arrow down to microphone at x1y2, and then arrow right, we are taken back to recording-output at x2y1. If we arrow right again, thre is no sound. That's because the connection ends here. That can be a little confusing, but keep playing around, and you will get it.

Hope this helps. Best regards Thomas