alarming IOS Bug

Hi all,
I posted a while ago, but don't think it went through so posting again.
I have a problem since I've updated to IOS 10 on my 6S, and that is that my alarm hasn't always gone off, so I assumed. After doing some tests while fully awake, I note that the alarm is quiet when phone is muted, and when unmuted, it has worked once at normal volume.
However, I had word on another list that others have had issues with the alarm going quiet when VO is turned on, so I shall try leaving VO off until this issue is fixed, so, yes, I smell possible bug here.
Has anyone else had this issue?
Thanks,
Cheers! :)

Forum: 

#1 audio ducking

Someone on above-mentioned list suggested that turning audioducking off may work in the meantime; though obviously this shouldn't be the issue in the first place. Just passing on feedback. :)

#2 so far i can't reproduce

hi, so far i can't reproduce this on my iPhone 6. so not sure if this might be a 6s particular bug or not. but so far, with voiceOver enabled or disabled, and mute on or off, alarms are working just fine.

#3 You might be right in that it

You might be right in that it's an IOS 6 issue; grrr

#4 Similar but opposite problem

I have a 6S runnoing IOS10. When my alarm goes off, VoiceOver volume goes up dramatically, louder than the alarm. It can be pretty startling. Audio ducking on/off doesn't seem to matter.

#5 Yes, that use to happen to me

Yes, that use to happen to me occasionally in previous IOS' What an alarm right?! Stupid VO issues!

#6 Replying to the alarm Bug and a possible contacts bug

So far, I haven't found a problem with the alarm, knock on wood. However, in my contacts, VO loses focus when I fill in the fields. I press edit, then Vo jumps where it feels like. I have to flick back and find it again. I found I had to do it with my Bluetooth keyboard. That's really not a problem because I use the keyboard lots. I only mention the keyboard because I don't see why using the keyboard or not would have anything to do with VO losing focus. I wanted to use braille at that time. I'm using the 6S+. I'll try again because it may have just been a fluke with my phone. Has anyone else experienced anything like this?

#7 I think I have a work around for the alarm bug.

Go to settings, double-tap sounds, switch off the change with buttons option. Then, adjust the volume by swiping up or down by one finger. I haven't tested the alarm yet, but this might help.
Thanks.

#8 Buggy volume control

I have not experienced that exact issue, but something very similar happened the other morning. My alarm went off as expected at the designated time. I snoozed it, and when I woke up a half hour later, I knew something wasn't quite right, LOL. I found that the dialog box to dismiss the alarm was on my screen, but I had never heard the audio the second time around of the alarm going off. I believe this has to do with the inconsistent and buggy volume controls in iOS, especially when voiceover is involved. Someone above mentioned disabling the option to adjust volume with the controls on the phone, and I do recommend taking that step. Even still, you will find that sometimes those buttons do adjust the volume of various sounds, in unpredictable ways. What they really need is a Windows-style sound mixer where you can have explicit control over various system sounds and applications. It is nearly impossible to understand how to dial in precise volume for different parts of the operating system. I think what may happen is, we are turning down the volume of music playback or VoiceOver output, and, Unintentionally, we have also turn down the volume of all system sounds, including alarms? This is my best guess. Long story short, I have always felt that volume control and VoiceOver were problematic in iOS.

#9 I turn up the volume before bed

I did over sleep my alarm once so I've taken to turning the volume of my phone up before bed. You have to be careful doing this that you don't turn off Voiceover but if you hit the up or down button with the home button it will give you a sound tone as well you can use to check your volume.

#10 Reported alarm issue to apple accessibility

Hello,
I reported my alarm issue to Apple accessibility. They asked me what tones I was using so still waiting on feedback. I found if audio ducking was on, the alarm would go quiet, irrespective of the tone I used. VoiceOver would become very loud even if audio ducking was off, however if audio ducking was off, the alarm would sound at its normal volume.

#11 resolved

Hi all, just an update. I turned off audioducking and the alarm is going off as normal with VO on. Though I have now got an iPhone 7, so not 100% sure if it's some how relating to an iPhone upgrade or if it's audioducking.
By and by, I didn't think I'd prefer the audioducking feature switched off but I actually do. :)
Thanks all for your suggestions. :)

#12 Audio ducking is the problem

Hello,
Audio ducking is the prlbem. I have an iPhone 6s. I have to turn it off to get the alarm to work. If I don't want voiceOver to sound louder, I have to turn it off before the alarm goes off.

#13 iOS 10.1

Hello,
I just tested the alarm so I can work out if my alarm is reliable for tomorrow without changing the audio ducking setting. Unfortunately the bug is still present. I thought this would be fixed in iOS 10.1. I might email Apple accessibility about this and I encourage others to do the same. Turning off audio ducking still results in voiceOver speaking too loudly.

#14 Upgrade to iOS 10.1

I had the issue with alarm on iPhone after updating to iOS 10 also. But mine is that it didn't go off sometimes. I guess iOS 10 has some bugs within the alarm app. That's why Apple has pushed new update 10.1 to fix this issue. After upgrading, my alarm works well again.
This guide on iPhonebyte has covered all the solutions to fix alarm errorsI think it may be helpful for some of you